Davinci on FW 16 (AMD 7040, Graphics Module, Windows 11) being unresponsive on start up

To provide some context, one of the main reasons I purchased a Framework laptop is my desire for more robust video editing software. I tried using Davinci on my previous laptop, but it would routinely crash due to its underpowered nature. After testing around the GPU a bit, I was confident I could run Davinci smoothly. However, Davinci seems continuously unresponsive once it reaches the Project Manager screen, an issue I never had on my previous laptop. I created a topic on Blackmagic Forum (Blackmagic Forum • View topic - Davinci Resolve 18.6.6, Hang on Project Manager Screen) around a month ago, but it’s been silent. I’ve seen other issues with those able to run Davinci smoothly on their FW16, so I wanted to see if others are encountering this issue or have any solutions.

This issue has been solved. It seemed like it had to do something with Python, so I uninstalled it and installed the latest stable version. I hope this helps someone!