Dedicated GPU malfunctioning

I just received my Framework Laptop 16 from batch 16. Mine comes with a Graphics Module (AMD Radeon™ RX 7700S). It worked the first time, but then randomly i turned it on today, and it said “usb device not recognize” (see image attached). I thought that was weird, so I launched a game, and for some reason rainbow six siege is running on a crappy 30 frames compared to yesterday’s awesome 144 frames. The GPU is just not working. I don’t know what to do, and I’m frankly freaking out. I would really appreciate it if someone could help, thank you in advance. I’m running windows 11. I’m also seeing this "unknown usb device (port reset failed) in my device manager
image

If you haven’t already, you should contact support. They may take a bit to get back to you, but they should be able to help you troubleshoot this. In the meantime, have you tried removing and reinstalling the GPU? I don’t believe that the GPU would show up as a USB device, but you could also try reinstalling the drivers in case that fixes your USB issues.

I just tried reinstalling the drivers. no dice. Thank you for your suggestion about the support and the reinstalling the GPU. I’ll try that right now. (if that doesn’t work I’ll contact support)

1 Like

I just reinstalled the gpu thank you so much it worked

1 Like