[RESPONDED] DisplayPort not working on Fedora 39 on 11th gen Intel FW 13"

Had this same issue last year with an HDMI port, so I went through and got a display port adapter instead. Now this isn’t working either. I just reinstalled Fedora 39 so I’m wondering if there are some drivers I forgot to install or something else I might’ve overlooked.

edit: will add more info on my system here later; as per Fedora General Troubleshooting

edit with more info:

  • 13 inch FW laptop DIY edition
  • 11th Gen Intel Core i7
  • Using GNOME.
  • Kernel: 6.7.9-200.fc39.x86_64
  • DP module did not work in any of the 4 slots.
  • Monitor (TV, really) did not respond in anyway to being plugged into the DP port.
  • DisplayPort module was found with lsusb
  • Cable used was DP to HDMI.

Not really my area of expertise, but a little more information might be useful, like:

  • Exactly what happens when you plug a monitor into the DP port. (“Absolutely nothing” is a valid answer, but it’s still useful to a troubleshooter.)
  • If you’ve tried the DP module in a different slot on the laptop.
  • If you’ve tried a different monitor or different DP module (assuming you have either available to you).

The first thing that I would try, were I in your shoes, is booting from a “live USB” drive and seeing if the DP module works in that environment. If it does, then the problem is software, perhaps a driver or something that’s gotten messed up in your configuration. If it doesn’t work in that environment either, then it could be a hardware problem.

Thanks for the response. I’ll add this information to the top.

Thanks. Did you try the “live USB” thing? It sounds like a hardware problem, but it’s always best to check.

Also, do you have a different cable to try?

Right now I would lean toward the problem being the cable, the DisplayPort module, or a driver problem, but that’s probably not an exhaustive list.

Welcome to the community!

That caught my eye. So this is not a standard DP to DP or HDMI to HDMI cable, but some sort of hybrid?