Displayport -> 3x 1080p HDMI?

I’ve had my Framework for seven months now, and overall I like it a lot. I have the Core i5 11th gen model, running Fedora 36.

I’m finally getting around to replacing my aging desktop with the Framework. I would ideally like to drive three 1080p external monitors while keeping the internal monitor active, giving me a four monitor setup.

My plan was to use the Displayport expansion card to do this via a DP MST to HDMI hub, but I now see both from this forum and from reviews of such hubs that success with such a setup is far from assured.

I’ve perused the docking station megathread and done other searches, but info on my specific situation seems limited.
I’ve found a few 3x and 4x Displayport to HDMI splitters. None are cheap and none have stellar reviews. Any feedback on which of these might be the best? Sorry for not providing links, I’m too new for the forum to allow that.

Tripp -Lite B156-003-HD-V2 (3x HDMI)
Tripp -Lite B156-004-HD-V2 (4x HDMI)
Startech MSTDP123HD (3x HDMI)
Startech MSTDP124DP (4x HDMI)

I could also run two monitors from the Displayport card and one from a USB-C docking station. My understanding is the Framework has two peripheral busses, one for each side of the device, so this would possibly allow greater bandwidth. The above brands both have DP → 2xHDMI units as does Cables to Go (#54293).

How am I most likely to succeed? Any quality brands that “just work”? I don’t want to spend months sending dongles back and forth and spending a fortune on shipping.

Thanks for any help!

Hi @McFly, I’d be happy to help!

My concern here is pushing three 1080p external monitors with integrated graphics. Not saying it’s impossible, but it’s a huge ask for the graphics configuration.

So it’s less about using a specific splitter, more about the “horse power” we’re using to push three external displays and the internal and still have it perform at any level that is usable. Usually, what happens is xrandr will show it as either there or not, and you’ll end up with black screens.

Myself personally, I would use multiple Framework laptops. Then I sprinkle in a little Barrier to allow me some KVM access between machines.

Then I’d have external monitors connected to each Framework. I realize this isn’t exactly what you’re looking for, but I swear by barrier for sidestepping stuff like this.

All of that said, you provide the monitors and the understanding this is super unlikely, I’d be happy to look at your xrandr output. But my opinion is that this won’t work well. Hopefully this provided some guidance.

Spoke to another member of the team, as long as you’re splitting things between both sides of the laptop (perhaps 2 on one side, 1 on the other), it should push this without any issue.

I’d go direct with the single monitor one side, with a splitter on the other side. I’d consider one of the Tripp-Lite splitters.

  • So 2 on one side, 1 on the other side of the Framework.
  • 2 Splitters in use.
  • Historically DP or HDMI should be fine, but I’ve had happier times with HDMI myself.

Some napkin math suggests this is very possible. Intel Ark states that a resolution of up to 7680x4320@60hz is possible from the iGPU over DisplayPort (I’m sure it will be struggling to do so, so I hope you don’t plan on doing anything graphically intensive). Given that 4K is 3840x2160 and 4K is essentially 4 1080p screens, I have confidence the iGPU can drive the panels but I think I would stick to DisplayPort over HDMI.

@Matt_Hartley What is the reasoning behind using multiple ports? One TB4 port should have more than enough bandwidth for this application. I use this excellent calculator to determine bandwidth and one TB4 port has plenty of bandwidth for all external displays and with DisplayPort, users can daisy chain the monitors together. That seems a much cleaner setup.

I grant you that the iGPU will chug doing this and is only suitable for web browsing and document editing but it should be doable, no?

This is largely why I felt like splitting things off would give us a better result. That said, yeah, I agree that one TB4 port should have the overall bandwidth. I simply prefer to spread things around a bit to accommodate three external monitors.

My reasoning for spreading to both sides was due to past experiences I’ve seen with iGPU not playing kindly (or at least consistently) giving weird xrandr results, etc.

But from a sheer bandwidth perspective, it should be just fine. :slight_smile:


Honesty I would not go back to Xorg if you are going to be pushing the limits of the graphics card. Wayland is likely to give better performance in this case. Wayland is the default for Fedora 36 anyway, so it might be best to leave xrandr out of it.

I think this is good advice, get a good TB docking station with multiple monitor ports in the dock and you’ll only have to deal with plugging/unplugging a single cable when you sit down at the monitors.


Ah, excellent observation. Spent so much time in Pop and other distros, still getting my Fedora land legs back. :slight_smile:

1 Like

While I was reading this I was thinking Synergy the whole time. I went and looked it up and it turns out this IS Synergy basically. The better feature-creep-less version that is. Thanks for sharing this. Very useful software!


I’ve had two sets of Framework DP modules now, but both sets only worked for a couple of days then failed to be detected and produced no display. This seems to be a common experience amongst Framework laptop owners wanting to use multiple external DP monitors. So, I bought two inexpensive “uni” USB-C to DisplayPort Cables (X0019RMW89) and plugged them into the USB-C ports in the vacant bays on my laptop after removing the faulty Framework DP modules and these cables work perfectly with my DP monitors. I now have the 4-display setup you want working perfectly: Laptop screen + HDMI + 2@DP.

There is clearly something wrong with the design/QC of the Framework DP modules because these USB-C-DP cables are working perfectly in the same ports that the Framework DP modules are not detected and don’t work.




Yeah it’s odd. We’ve seen mixed experiences. We have staff that absolutely do it (on Linux) without issue, but there are a number of variables. Cables, monitor, etc. Myself, historically, I keep an adapter handy. :slight_smile:

1 Like

Well, I’ve used these monitors and cables on many different computers with all sorts of different OS’s and never had a problem until I tried to use the Framework DP modules.

How can you explain the DP modules not being detected on the USB?

Furthermore, I tried the Framework DP modules on three other DP monitors…

I must admit Tony, that is odd. Usually stuff like this is pretty binary - it either works or it doesn’t. So for it to work, then fail after a few days is really odd.

I have a fresh batch of DP modules coming to me in the coming days, I’d be happy to see if I can replicate this. My main Framework has Fedora 37 (RC0 on it, but I can set one up with Fedora 36 to see if I can replicate this.

My Fedora 37 RC install uses Wayland by default, can you check to see if this behavior repeats if you select Gnome on Xorg? My goal is to eliminate anything OS/Software based here. Log out, click the cog in the lower right, select Gnome on Xorg - if it does this again there, please let me know.

From a simply replicate the issue perspective, once I receive my additional DP adapters, I will work to mimic this behavior so I can dive into the logs and see what is happening.

1 Like

Hi, Matt.

I’m experienced in building computers and installing software: I’ve tried hard to find out what the problem is with the two sets of Framework DP modules I’ve had. Check my customer support emails to see where I am with my support call. I thought the problem was resolved when I got the replacements, but I was very disappointed to see the same problem happen again after only a couple of days.

You must be aware that other people on the Framework Forums have reported similar problems. It’s frustrating for me to report a genuine problem with one of your products and be told that its my DP cables and/or monitors that are at fault when these have worked flawlessly with several generations of my high-spec graphics cards. My Framework DP modules also failed to work on other DP monitors I tried.

I bought two USB-C-DP adapter cables to check if my Framework laptop USB-C is working properly. My two DP monitors work perfectly with these cables plugged into the same USB-C ports that the Framework DP modules don’t work in (i.e. failed after a couple of days). I’ll be sending the DP modules back as soon as I get a return shipping label from Framework support.

I’m very pleased with my Framework laptop and I posted my message about the USB-C-DP adapter cables to help anyone else in the same position that I found myself in. If this is a manufacturing QC issue, you will not be able to replicate it unless you have the misfortune of using DP modules from a ‘bad’ batch, or you get hold of the DP modules I return and test them yourself.

The problem is that four Framework DP modules that I was sent all, eventually, failed to be detected by the Linux kernel in a way that other people have also reported. However, I want to get on and use my laptop so I have come up with a work-around the problem using USB-C-DP adapter cables. I hope you do get to the bottom of the problem that I and other people have reported, because I think the Framework laptop is great!



I completely feel your frustration and yes, I would like to get to the bottom of it. My job is to advocate for you, to get this resolved. But the process is messy and for that I apologize.

My approach differs in that I am not here to simply push this off as a one off issue, rather, attempt to duplicate it. I too, will be using new modules to attempt to replicate the problem. I will be putting in the work to gather data so we can see what is happening and what needs to happen next.

Part of this process means I will be dedicating a Framework laptop that matches your configuration as much as possible.

So what does all of this mean?

We have you finding that DP modules work for a little bit, but then fail. As you know as someone who has built computers, there are two attack surfaces I am facing - OS and hardware.

It very well may be bad modules happening here, however, I need to verify on my end (with my own mimicked configuration) that this isn’t something with Fedora.

This means testing different display servers, kernels, etc.

If I cannot replicate this and I don’t see anything useful in my logs. Then I have something I can present as a potential QA issue. On the other hand, I find that this is simply a matter of the kernel issue, this also gives me something I can take to my team going forward.

And please, feel free to message me directly anytime. My job is to provide you with support and to make sure your Framework laptop, is working with Fedora as it should. I appreciate your patience as I dig into this further.

I have set a reminder to circle back to this for testing once my new modules arrive and you will definitely hear back from me on this. Really appreciate your feedback and insights on this.


Hi, Matt.

I’m using Ubuntu-MATE 22.04 LTS, not Fedora. However, I did install the Framework-supported version of Ubuntu 22.04 LTS (i.e. Gnome3 desktop) to test the DP modules when I was asked to by Framework customer support, but I got exactly the same kernel error messages about resetting the USB devices etc. I sent some of my logs to customer support. This is not surprising, since both versions of Ubuntu use he same kernel. At the risk of repeating myself, the USB-C ports on my laptop worked fine with a Framework HDMI or USB-A module in the same USB-C ports that DP modules failed to work in after a couple of days use. The HDMI and USB-A modules worked perfectly when swapped for the DP modules. My laptop is working perfectly now, with USB-C-DP adapter cables.

Thanks for your helpful reply,


Thanks Tony, I appreciate this. I also received your other message and replied there as well. This will absolutely be getting attention. Details in the direct message.

Appreciate it!

1 Like

Sorry to be away with a busy few days. It seems I started a lively discussion.

I’m so pleased to see a member of the Framework team here responding to customer questions. It’s such a rarity to see.

To answer one of the earliest questions - I will not be doing graphically intensive tasks on this setup, just desktop applications. Given the basic math, my setup will be about 9 MP of total resolution, and the total bandwidth mentioned above is almost 3x that much. I hope the integrated graphics can handle desktop applications at 1/3 the specified bandwidth.

I think I’ll go with two adapters: a charging/USB/HDMI adapter for the USB-C port, and a 2-port DVI → HDMI adapter for the Displayport card. I’ve noted that many of the negative reviews of the Displayport MST hubs show them working with two monitors, but failing once more are plugged in.

Thanks for all the help, I’ll update here once I get the hardware and try to make it work.

I push an external 4K 60hz display, and I have for the last few generations of integrated Intel graphics. I don’t think that the Intel Iris Xe is going to be the limiting factor.

I’ve been using my 11th-gen Framework with a pair of 3840x2560 displays via native USBC (one cable to each side of the laptop) for about a month. Mostly for work, but a little play as well.

It’s been reliable and I haven’t noted performance issues. Mostly Chrome instances across 5 virtual desktops and the internal display active. Windows 11.


Excellent to hear everyone, thanks for sharing your experiences! :slight_smile:

Based on my own testing over the weekend, I would agree with the community sentiment. I used direct connections (DP and HDMI), but so long as the laptop remains usable (without too much lag), you should be okay.