DIY gen 11 won't turn on

I put my 11th gen DIY framework laptop to sleep while plugged in yesterday and I haven’t been able to get it to turn on again.

Yesterday when I pressed the power button it would turn red, then flash off and on red again. The LEDs on the side didn’t really make a pattern, but they appeared to be turning on briefly (white?) when I pressed the power button.

After draining the battery overnight, the power button and side LEDs don’t light up at all even when plugged in.

Based on some troubleshooting advice I saw in other threads on this forum I tried:

  • Booting from an external USB stick (I couldn’t get to the boot menu)
  • Holding down the power button for 15 seconds in case it was caught in sleep (no change after several attempts)
  • Letting the battery charge in case it was out of power
  • Letting the battery drain overnight because I was out of ideas :slight_smile:

I haven’t installed any new components recently, the laptop tends to stay plugged in at my desk most of the time.

Edit: I’ll get in touch with framework support too, but I’m asking here because I use an unsupported linux. Last time I tried to ask a hardware question I didn’t get far with support. If anyone has ideas for how to troubleshoot this I would appreciate the help! Thanks!

Try this, but please be careful when removing the RTC battery as its holder is extremely fragile: Fully Resetting the Mainboard State - Framework Guides

I would also reach out to Support as it’s possible that your RTC battery is no longer holding a charge, and they will send out a new one.

Best of luck, I hope that you’re able to get your system back on its feet. Have a great day!


This is the recommended course.