Every time I try and boot into my efi boot device with manjaro on it I get nothing

I hit enter on the boot device and the same menu keeps coming up, this is very fustrating


Try a search for “boot issue” there are a few threads that may be of help.

You might want to include more detailed information about the menu you are seeing etc.

I did the search and found nothing relevent to my issue.

Isee boot manager

boot option menu

then one option for my flash drive that is highlighted.

I click enter

flash to black

same menu reappears, there are no more details

1 Like

fedora seems bootable. will try manjaro again.

still didn’t work, no manjaro for me i guess

This is also a reason I don’t use Manjaro. I have a desktop I built myself that could not install that distro for whatever reason, but all other distro’s installers worked fine. I just use PopOS now

1 Like

anyone finding this with the same issue, make sure you disable secure boot in bios (f2 at boot) before trying to install OS


now wifi is not working out of the box and all the resources I am finding are saying i need to tether the laptop to update the system to get it to work. I’m just going to go with pop os, wifi appears to be working out of the box.

1 Like

Manjaro 21.1.2 GNOME worked right out of the box for me except fingerprint. I have given up on that because my fingerprints from previous Ubuntu installation are still stored in the fingerprint reader’s firmware and I don’t know how to erase them and re-enroll. Fingerprint reader disconnects as soon as I try to enroll a new fingerprint. Manjaro does come with the latest libfprint (v1.94) which is great (compiling it from source on Ubuntu was a pain). The other minor gotcha was to run gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']" to get fractional scaling options (between 100% and 200%) to show up in the display settings menu. I have been a long time Ubuntu user (~10 years) and this is my first time trying a different Linux flavor. Manjaro feels snappier and slightly less power hungry on my Framework than Ubuntu 21.04.

I haven’t tried Manjaro specifically, but I was able to get wifi working with stock Arch using iwd.

I’ve posted my install notes here.

Same issue here, Thought I made a bad boot drive. built mine at work today was sad that I couldn’t play with it all day. tried again at home same deal, gnome(pop!_os) worked without a hitch. good luck!

Question about the boot issues you are running into. Does the installer load, and you are able to install the OS, then after installation, you can’t boot into the new OS? Is the installer not booting? What part fails? I had to re-create my EFI boot partitions for Slackware to get everything to boot as expected. I needed to rename my .efi file and I needed to include the .conf as well. I moved my folder that used to be labeled Slackware as “boot”, then have my initrd.gz, vmlinuz, bootx64.efi and elilo.cfg (i also have elilo.conf because i cant remember which was the correct naming and haven’t taken the time to remove one and check) Just curious if you are seeing someting similar, and if renaming / moving or copying things around helps. Someone also posted on here the command they used to add their specific efi boot file to the boot sequence. If I find it again, I’ll add a link.

I have the same issue. Booting with Arch Linux; black screen after efi menu in bootloader.

I disabled secure boot and it worked. Why is that?

The reason it doesn’t let you boot into Linux is because Secure Boot only lets bootloaders signed by Microsoft to boot.