I can boot USB from other computers but not this one despite me doing so in the past

I am a bit confused here. I have booted from USB live sessions from Linux distributions in the past however I cannot do this anymore. I haven’t changed the bios since I have received the laptop. I managed to boot from Manjaro, Fedora, Ubuntu and Linux Mint in the past but tonight I was trying to switch to Manjaro from Linux Mint. When trying to enter the boot via F2 or F12, it will allow me to select but will not boot using these options. It shows up but when selected it doesn’t do anything. As a test I tried booting the USB stick from my desktop, works fine. Just really baffles me when I could do this back in October of last year but not March of this year.

Is secure boot disabled ?

1 Like

What method did you choose for creating your Manjaro boot media?

I had the same problem trying to install literally any Linux distro, I fixed it by accident when I somehow found the bios reset button. no idea where it is or even what it’s called, but I did that then re-did all the changes I liked, and suddenly everything worked perfectly. I have a feeling a boot manager from something was stuck as first priority when it shouldn’t have been.

Feeling a little like an idiot but it was the secure boot issue that the first person to reply to this suggested to check. I would of checked that but as mentioned, I didn’t change anything that would of made me think to look at that. Anyways, after seeing that and changing it, was able to boot the live USB. Manjaro works really well out whereas Linux Mint required the edge version and immediate kernel change to make it work with the wifi card I had ordered.