[RESPONDED] Manjaro disappear from boot menu on 12th Gen Intel CPU upgrade

I recently upgraded to the 12th Gen Intel main board and my Manjaro boot option is gone from the boot menu. I tried disabling secure boot from bios but it’s still not there. The partition is still there and my files are in tact when I check from other OS’s and it shows up under os-prober, but it’s gone from bios and grub. Any help would be great appreciated!

Try to mount your partitions using a live ISO and then run update-grub within a chroot.

Verify boot entries using efibootmgr afterwards, maybe even forcing a write with efibootmgr -w.

You can find more information online on how to do that on your distro.

Agreed with the above suggestion, also might be worth looking into:

Eventually got it working by booting into another distro on this system. It was strange that it just disappeared though. Also now I have a problem with the brightness adjustment not being possible: looking into that next.

Its an already known issue and its mitigation is already on the public framework guide.

1 Like