F2 will not enter bios on startup running win11 home AMD bios 3.05

Framework 13 AMD latest version. I just got it last week. win11home. bios 3.05

I can’t get the bios or boot page when holding F2 or F12. I tried all variations of the knowledge base tips other than external keyboard.

I do get the the Framework screen but it never goes into bios or boot.

I can reach the bios using windows → settings → system → recovery → advanced start.

Have you tried mashing F2 while turning on the laptop from shutdown?

You may want to try disabling fast startup if that’s enabled, starting from a complete shutdown and not Windows partial hibernation state that fast startup tends to create for itself. This may help, also.

1 Like

I had a similar issue but I was able to get into the bios by smashing the FN key and the F2 key.


Disable fast boot:


In addition, holding down F2 then hitting the power button doesn’t work. What works it hitting the power button and toggling the F2 key.

I got this solution from the framework subreddit. In that post I was cautions not to disable quiet boot and quick boot. However I went in the bios and disabled both of them and the boot procedure works.

This is probably one of those “your mileage may vary” things since the knowledge base looked a little bit of try this then try that.

When I have my dual boot working I would like to get this suggestion in the knowledge base. Does support read the community or do I need to contact them directly.

As a linux user and occasional windows user, windows gets worse with every version. I had to google how to find the shutdown FFS!

This is what @Blake_Galbraith was telling you to do in their post. And yes, Windows rebranding hibernate as shutdown has caused all sorts of headaches – a reboot is, in fact, more of a shutdown than a shutdown is out of the box now.

[For context: I happen to know about this “feature” because it bit me in the butt professionally; it causes loads more extremely subtle problems than just this. Even Windows trips itself up with it. Despite the bizarre consequences it brings, it’s been turned on by default in Windows 10 for five or six years now, but if you don’t use Windows much, it’s understandable that you probably haven’t hit it, or realized it’s a thing.]