Fedora 35: Bluetooth Not Working Out Of The Box

System Information

Processor: Intel i7-1165G7(12M Cache, up to 4.70 GHz)
WiFi: Intel Wi-Fi 6E AX210 No vPro
Storage: Hynix Gold P31
Memory: 32 GB (1 x 32GB) DDR4-3200
BIOS: 3.07


OS: Fedora Linux 35
Kernel: 5.17.4-200
DE: Gnome 41.4

I want to use bluetooth on my laptop, but Fedora does not seem to detect it out of the box. The Wifi card does support Bluetooth 5.2 (Product Brief: Intel® Wi-Fi 6E AX210 (Gig+) Module).

It is my understanding from this post that Bluetooth should work by default with Fedora 35. I used neofetch to verify that my version of Fedora is in fact 35. Moreover, I’ve tried updating via sudo dnf upgrade --refresh and restarting my computer, but still nothing shows up in the settings menu.

I’m a bit at a loss about what to do. WiFi works fine, so my guess is that the Intel Wi-Fi 6E AX210 No vPro is working fine as well. I’m assuming it’s probably a software problem, but I don’t know how to troubleshoot it further. If you could give me some ideas, I would appreciate it!

1 Like

I have nearly the exact same software (F35 w/ latest kernel) and hardware (16GBx2 on the RAM instead of 32GBx1) and Bluetooth does work for me - has from day 1. Try running lsusb in Terminal - you should get something like Intel Corp. AX210 Bluetooth in the output. If you don’t see that, then I would tend to think hardware issue, not software.

1 Like

@gjason I ran the command you suggested and got the following:

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 27c6:609c Shenzhen Goodix Technology Co.,Ltd. Goodix USB2.0 MISC
Bus 003 Device 002: ID 32ac:0002 Framework HDMI Expansion Card
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 090c:3350 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) USB DISK
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

It’s not showing Intel Corp. AX210 Bluetooth. I’ll try opening up the laptop and reinserting the Intel Wi-Fi 6E AX210 No vPro module. If that does not work, I’ll wait 48 hours for any other suggestions people might have, then I’ll try to contact Framework Support. I have been unable to get Bluetooth working on any of the other distros I’ve tried (like Ubuntu/Manjaro), so I’m starting to lean towards a hardware problem.

1 Like

Quick update: I opened my laptop and reset the Intel Wi-Fi 6E AX210 No vPro module. As I did the first time around (I got the DIY edition), I carefully followed the Quick Start Guide (Specifically Step 7). Unfortunately, I still have no Bluetooth connectivity.

I’m still open to any other troubleshooting steps that anyone might have.

1 Like

@Hephaestus Do you have any bluetooth related errors in your journal?

sudo journalctl -k -p3 --no-pager

-p filters for message priority. 3 are errors. If you want to have a look at warnings use 4.

@43c I ran the command you suggested (sudo journalctl -k -p4 --no-pager) and received the following output:

As far as I can tell, none of the errors/warnings are related to Bluetooth. If you see/understand something I do not, your input would be appreciated.

Well, you definitely have issues with an USB device as it cannot be recognized and fails initialization (usb-3-10 errors). Also since lsusb does not list ID 8087:0032 Intel Corp. AX210 Bluetooth I assume your card might be faulty. The last thing you can try is to take it out and see if the errors disappear. You should contact Framework support about your issue.

For reference, this is what lsusb shows without any extension card on my system:

1 Like

@43c I removed the card and ran the same command as before (sudo journalctl -k -p4 --no-pager). As you suspected, the USB3-10 errors (like usb 3-10: device descriptor read/64, error -71 or usb usb3-port10: unable to enumerate USB device) disappeared.

I still had the “pci 0000:00:07.0: DPC: RP PIO log size 0 is invalid” errors, but some research shows that those are related to the Linux kernel and Intel’s 11th gen CPUs (tiger lake). This seems to suggest to me that the ntel Wi-Fi 6E AX210 No vPro card may indeed be faulty.

I’ll be contacting Framework support about the issue some time tomorrow.