Fedora 39 on the Framework Laptop 13

We touched on some of this here.

Note that 7040 Series is still a very new platform and AMD’s open source teams will continue to actively develop and improve Linux kernel driver support beyond this specific firmware fix. We’ll keep updating our guides to point you to recommended configurations, and we’ve created a Community wiki post (here) with an overview of the latest status.

With BIOS 3.02, lid events and suspend operate, but, we’re actively working on the next BIOS release that will address issues folks have experienced.

2 Likes

Thank you!

1 Like

I renamed this thread’s title from “[Fedora 39] Official Fedora 39 Thread” to “[Fedora 39] on the Framework Laptop”, referring to the other official thread [Ubuntu 22.04] on the Framework Laptop and previous version Fedora 37 official thread Fedora 37 on the Framework Laptop . My guess is that Matt wants to use the “[Fedora 39]” for his email filtering. So, I kept it. I hope you still like this title.

2 Likes

3.03 firmware has fixed all my gripes.

1 Like

Looks good to me. :slight_smile:

1 Like

Just a reminder for AMD 7040 Series owners, the new beta BIOS is out - please update: AMD Ryzen 7040 Series BIOS 3.03 and Driver Bundle Beta

@Matt_Hartley My power consumption (with lid closed) improved with BIOS 3.03 to about 12% in 10 hours on a 61Wh battery. Is AMD further working on this topic?

EDIT: Using an up-to-date Fedora 39 beta and BIOS 3.03 on my 7840U Framework 13. Rear slots both have USB-C expansion cards, front left USB-A, and front right Micro-SD. The device was powered on, but the lid closed after checking the initial battery percentage.

We endeavor to improve battery performance wherever possible.

As it’s suspending to RAM, I expect there is to be some loss there. This sounds about right based on your setup.

I installed Fedora 39 beta (On the AMD 13"), and after the initial install, it rand a software update and got various updates as one would expect. Great. But since then, nothing.

Checking for updates on command line and in the Software app, I get nothing. It’s been almost a week, and no updates at all. I assume something is gummed up, but I don’t know how to resolve it.

I’ve updated to the 3.03 bios, and this has made my new machine much more viable. I suspect that one of the many many hard crashes I had on the 3.02 bios caused this issue.

I’m willing to wipe the drive and reinstall Fedora, but if there’s a way to fix the problem I’d prefer that.

I upgraded to kernel-6.5.9-300 tonight and it’s causing amdgpu to throw a lot of errors. FW 13 AMD

[ 1482.824984] amdgpu 0000:c1:00.0: amdgpu: [mmhub] page fault (src_id:0 ring:40 vmid:1 pasid:32773, for process RDD Process pid 3952 thread firefox:cs0 pid 4352)
[ 1482.824986] amdgpu 0000:c1:00.0: amdgpu:   in page starting at address 0x0000000000000000 from client 18
[ 1482.824988] amdgpu 0000:c1:00.0: amdgpu: MMVM_L2_PROTECTION_FAULT_STATUS:0x00000000
[ 1482.824990] amdgpu 0000:c1:00.0: amdgpu: 	 Faulty UTCL2 client ID: VMC (0x0)
[ 1482.824992] amdgpu 0000:c1:00.0: amdgpu: 	 MORE_FAULTS: 0x0
[ 1482.824993] amdgpu 0000:c1:00.0: amdgpu: 	 WALKER_ERROR: 0x0
[ 1482.824995] amdgpu 0000:c1:00.0: amdgpu: 	 PERMISSION_FAULTS: 0x0
[ 1482.824996] amdgpu 0000:c1:00.0: amdgpu: 	 MAPPING_ERROR: 0x0
[ 1482.824998] amdgpu 0000:c1:00.0: amdgpu: 	 RW: 0x0

I will rollback the update for now.

jim@fedora:~$ sudo dnf history info 19
Transaction ID : 19
Begin time     : Thu 26 Oct 2023 09:56:52 PM EDT
Begin rpmdb    : 17a6f5f667197f6e80f3ddc64e6ed3fbdbb3a23b58192a2113e35824b0cf5354
End time       : Thu 26 Oct 2023 09:57:31 PM EDT (39 seconds)
End rpmdb      : 4402b76213a8d7a7d3a9adab73478d4811b86b6f31aedd0e55f4be813cbef8a9
User           : Jim <jim>
Return-Code    : Success
Releasever     : 39
Command Line   : update -y
Comment        : 
Packages Altered:
    Install  kernel-6.5.9-300.fc39.x86_64                  @updates-testing
    Install  kernel-core-6.5.9-300.fc39.x86_64             @updates-testing
    Install  kernel-modules-6.5.9-300.fc39.x86_64          @updates-testing
    Install  kernel-modules-core-6.5.9-300.fc39.x86_64     @updates-testing
    Install  kernel-modules-extra-6.5.9-300.fc39.x86_64    @updates-testing
    Upgrade  freerdp-libs-2:2.11.2-3.fc39.x86_64           @updates-testing
    Upgraded freerdp-libs-2:2.11.2-1.fc39.x86_64           @@System
    Upgrade  ibus-1.5.29~rc1-6.fc39.x86_64                 @updates-testing
    Upgraded ibus-1.5.29~rc1-5.fc39.x86_64                 @@System
    Upgrade  ibus-gtk3-1.5.29~rc1-6.fc39.x86_64            @updates-testing
    Upgraded ibus-gtk3-1.5.29~rc1-5.fc39.x86_64            @@System
    Upgrade  ibus-gtk4-1.5.29~rc1-6.fc39.x86_64            @updates-testing
    Upgraded ibus-gtk4-1.5.29~rc1-5.fc39.x86_64            @@System
    Upgrade  ibus-libs-1.5.29~rc1-6.fc39.x86_64            @updates-testing
    Upgraded ibus-libs-1.5.29~rc1-5.fc39.x86_64            @@System
    Upgrade  ibus-setup-1.5.29~rc1-6.fc39.noarch           @updates-testing
    Upgraded ibus-setup-1.5.29~rc1-5.fc39.noarch           @@System
    Upgrade  libwinpr-2:2.11.2-3.fc39.x86_64               @updates-testing
    Upgraded libwinpr-2:2.11.2-1.fc39.x86_64               @@System
    Upgrade  xorg-x11-server-Xorg-1.20.14-26.fc39.x86_64   @updates-testing
    Upgraded xorg-x11-server-Xorg-1.20.14-24.fc39.x86_64   @@System
    Upgrade  xorg-x11-server-Xwayland-23.2.1-2.fc39.x86_64 @updates-testing
    Upgraded xorg-x11-server-Xwayland-23.2.1-1.fc39.x86_64 @@System
    Upgrade  xorg-x11-server-common-1.20.14-26.fc39.x86_64 @updates-testing
    Upgraded xorg-x11-server-common-1.20.14-24.fc39.x86_64 @@System

Fedora 39 is in the final freeze before release, this means only critical fixes will be published, no routine feature update. This is normal, and will change after release.

1 Like

There was a freeze recently as they prepare for an official launch.

If the log noise is followed by actual issues, please see this thread.

1 Like

hey guys, so i’m still having issues with firefox and video playback. i’ve done all the suggestions in this thread and have gotten videos to work, however the videos stutter every 10 seconds or so. like they freeze for a few seconds then catch back up while the audio keeps playing – making videos essentially unwatchable on firefox.

does anyone use firefox and have this issue? i’ve moved over to using brave which has no issues, but i’d really prefer to be using firefox but the video playback is killing me.

i’m on the latest update of fedora 39, 3.03 bios, and i’ve tried the flatpak and rpm version of firefox and they both have the same issue.

If you’re talking about HTML5 video playback, please do this here:

1 Like

Fedora Linux 39 was released today!

@Matt_Hartley Could you update the first comment on this thread?

Ha! You totally beat me to it! Yep, doing so now. :slight_smile:

1 Like

Just a FYI if you are running Fedora and want VAAPI profiles exposed then you need to enable rpmfusion and run the steps listed here:

https://rpmfusion.org/Howto/Multimedia

To expose the various capabilities via vaapi for encode/decode - fedora strips patent encumbered bits from mesa by default. IME people forget to run the dnf swap bits after adding rpmfusion .

You can check what is exposed by installing libva-utils and running vainfo

2 Likes

I’m having an with Youtube videos in Firefox on Fedora 39, 6.5.11 Kernel (happened on previous kernels as well), 3.03 BIOS. Audio plays smooth, but video temporarily freezes or stutters for a bit then catches back up and plays smoothly for a bit. This happens at random, inconsistent intervals. Sometimes is merely and annoyance, sometimes it’s to the point of making the video completely unwatchable. It doesn’t seem resolution dependent. This will sometimes happen at 720p resolution and sometimes even 4K60 videos will play smooth. But that’s not the main oddity to this issue. Videos play fine with wired headphones and when using the inbuilt speakers. But if I use bluetooth earbuds, this video freezing and stuttering issue occurs. I can disconnect my bluetooth earbuds and the video will start playing smooth. Re-connect my bluetooth earbuds and the video will start getting choppy again.

This issue is unchanged whether I have the system in Power Saver, Balanced, or Performance modes. Also, I have the GPU set to “game mode” in the BIOS. I haven’t seen any graphical glitches or issues some people have had, just this video stuttering issue with videos while using bluetooth earbuds. This happens on battery and when plugged into a charger.

2 Likes

@BigT ; yup I noticed this also with the fc39 kernel; also happens in ublue/silverblue as well as workstation and in Plasma or Gnome; i’ve moved to using rawhide over the weekend and will be watching over the next couple of days for it.

2 Likes