Fedora 40 KDE, 13/AMD, Laptop keeps waking itself up

Currently using Fedora 40 KDE after having upgraded from Fedora 39 KDE, running on the latest BIOS for this mainboard (3.05). My AMD (7840U) Framework 13 keeps waking itself up whenever I make it go to sleep.

It happens regardless whether:

  • Everything is left plugged in
  • My monitor is plugged in
  • Peripherals are plugged in
  • Neither my monitor or peripherals are plugged in
  • And any of the above when I close the lid instead of having the laptop go to sleep via software instead

When everything is left plugged in the laptop will immediately wake itself up the moment it goes to sleep. But for the other scenarios it can sometimes take a few minutes, up to an hour or two, before it wakes itself up again.

The only things I haven’t tried unplugging when my laptop is asleep are its power cable and ethernet through the official expansion card. (I’m having the laptop go to sleep whenever I’m going to bed, and I don’t think ethernet can wake up a laptop respectively.)

Any suggestions on fixing this?

I noticed the same thing on my FW16. It did work using default settings, but when I changed the setting to require the laptop to be locked when waking from sleep, sleep doesn’t work anymore. When I put the laptop to sleep, it will wake up immediately. In my case only a mouse (USB-C) and the power supply was connected.

I’m not sure if it’s kernel version related, but I expect so. I need to experiment a bit more, but lack the time to do so.

Have you tried this? linux-docs/Fedora39-amd-fw13.md at main · FrameworkComputer/linux-docs · GitHub

Tried it just now, nothing was changed unfortunately.