[RESPONDED] Fedora 39 - Unexpected wake from sleep w/ external monitor

I’ve been experiencing regular wake ups when my AMD framework 13 is connected to my external monitor through an HDMI expansion card and cable. Not sure 100% if the monitor is the culprit, but most days it ends up connected to it while it charges overnight, and I wake up to it awake on the login screen. Which is another weird symptom because with my normal settings it should put itself back to sleep after 10 minutes even while plugged in. I also usually have a USB3 hub attached with some peripherals but I tested it by unplugging it overnight and had the same result.

I’ve started just shutting down most nights but for diagnosis purposes I can always try again.

How do I log “wake” events?

Use the s2idle script with the timer programmed for a longer sleep cycle than you intend to really use. It will catch the interrupt that woke the system in the report.

1 Like

Thanks. Caught an unintended wakeup today, here’s the output: 2024-01-03 12:06:56,847 INFO: Debugging script for s2idle on AMD systems2024-0 - Pastebin.com

It happened while I was sitting in front of it watching my phone, just a few minutes after I started the script. It looks like maybe this is the event?
2024-01-03 12:12:28,030 INFO: ○ Woke up from IRQ 1 (IR-IO-APIC 1-edge i8042)

Fix the stuff it told you at the end. The rtc thing specifically should help.

1 Like

@Seth_Merkley which distro are you on? The script Mario recommended is awesome and saves us so much time. Looks like you’re dealing with:

On Fedora 39, I believe they applied a patch addressing the ACPI issue?

Nonetheless, on other distros: adding rtc_cmos.use_acpi_alarm=1 to your boot parameters will also address the issue seen here.

Ubuntu for example:

Editing /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash rtc_cmos.use_acpi_alarm=1"

sudo update-grub


It seems like Fedora but an old kernel that doesn’t have the patch to me from the debug report.

1 Like

Ahh, yes, I see it now.

|2024-01-03 12:06:56,848 INFO:|🐧 Fedora Linux 39 (Workstation Edition)|
|2024-01-03 12:06:56,848 INFO:|🐧 Kernel 6.5.2-301.fc39.x86_64|

Oh my, yeah, that is in need of an update. We should be looking at 6.6.8+

@Seth_Merkley please run this and reboot:

sudo dnf update -y
Then reboot and run the python script again.

(@Matt_Hartley ISTR this has been made “sticky” in some guide but I couldn’t find it.)

@Seth_Merkley you might also want to check this to make sure that you default to booting into the most-recently-installed kernel:

and/or just hit Esc while the FW logo is displayed during boot to get the grub menu and select the most recent kernel.

Thanks for all the tips. Got back to this today, I run all the latest updates so I indeed wasn’t booting into the latest kernel. Here’s the output after manually booting with grub: 2024-01-09 17:54:39,133 INFO: Debugging script for s2idle on AMD systems2024-0 - Pastebin.com

I just used the default timings to see if the error cleared and it looks like it has. I’ll go back to using sleep mode and report back if I have any issues, thanks!