"File is corrupted" - Cannot install the Framework Driver Bundle

I have just completed the setup and installation Framework DIY laptop. When attempting to install the Framework Driver Bundle, I’m always receiving an error message “file is corruption”. I downloaded and tried to install multiple time the bundle, but no matter what, I’m always receiving the error message.

Also, I can’t access internet on my Framework. Windows is saying that I’m missing a driver (which I cannot install since I can’t install the Bundle).

I verified twice and the wifi module seems to be correctly installed.

Any help on that?

Can you try installing it on a different computer onto a USB and then using that USB to install it?

Thanks Josh for replying but I have already tried using a different computer.

I installed Windows with the same USB key therefore I don’t think the problem is the USB neither.

Would you be able to share a photo of the error that is occurring?

I finally installed the Driver Bundle! I have done it by sharing my phone wifi connection by USB cable and I downloaded the Bundle directly on my Framework. The problem was probably my USB stick.

1 Like