First boot, no display

Hello all

So, today I put together my framework 13 13th gen Intel laptop for the first time. I had a lot of fun with it, however, that fun was sort of ruined when I encountered issues with my first boot. It was supposed to be doing memory training, which typically takes 1-2 minutes, especially considering I installed 32gb memory (1x32gb crucial). I left it 20 minutes and still no luck with getting a display. The laptop was getting hot and the fans were loud so I powered it off and tried again, no luck. I tried once more, reseating the memory, but no luck. I’ve not seen any diagnostic LEDs, just the orange LED to say it’s charging and briefly green on the right side when I powered it on (only for a second, then the green disappeared).

I have contacted support about this, however, it’s outside normal working hours and I wanted to hear from others who have had similar problems. If you’ve got anything to share, please do, I’d really appreciate it

Have you tryed to reconnect the Dissplay?


I left it to charge for a while, then tried again. This time I got the diagnostic blinks on the side and the 11th blink was red, which apparently means it’s going to be a memory issue. I’m going to test the ram in the other channel and if the issue still persists then it’s likely an issue with my memory and not frameworks fault, I’ll try now

It seems that it’s a fault with my memory. 11th blink same as the other channel

1 Like

I will continue to update this post as I find out more, but I’ve ordered a replacement RAM stick from amazon and it should arrive tomorrow, if that works then problem solved.

I’m concerned that the LEDs didn’t blink the first couple attempts at powering on the laptop, but I’m going to chalk that up to not having enough charge because they worked perfectly fine once fully charged

@Codey So did you reseat the Display Connector?

it´s worth a try.

1 Like

@Ian_Thomas I hadn’t tried it, the diagnostic LEDs showed green for the display. My replacement memory will be arriving tomorrow and if that doesn’t fix my problem then I will look into issues with the display

Which 32GB crucial module did you order? Originally and now for replacement?

@Scott_H it was CT32G4SFD832A which is said to be compatible by framework. I’ve got the same coming for replacement in a few hours from now.

Should work. Hopefully you just got a defective module.

Good news! It was indeed a defective module. The replacement RAM arrived and it booted without issue!