Framework Not Booting - possibly a CPU issue

I did start a ticket with support over this issue, but just wanted to see if I’m crazy and just not doing things right.

I put my DIY edition together with Gskill 3200mhz RAM with CS 22-22-22-52 and an intel nvme ssd (3rd gen pcie incase that matters) When I try to boot it it just gives me a blank screen and pressing both the bios button and the boot menu button does not drop me to anything either. The LED codes tell me that everything is green except for the following

CPU deassert sleep S4
CPU reached S0 state

and some times the cpu fan one is red as well.

I think from the error codes its a cpu issue and I’ll need a new board, but just wanted to ask the community to see if I’m missing something obvious.

support is gonna ship me a new unit, so I’ll be good

replacment works great, swapped the motherboard in and I’m writing this from the framework laptop now!


Is it any different with only one RAM stuck installed?

nope, and I swapped the ram with a different stick in another laptop that is working properly, so I’m pretty sure I’ve ruled out the RAM.

The only other thought I have is to remove the SSD and all expansion cards. If that doesn’t help then the diagnostic codes do seem to indicate a serious issue.

yeah I’ve already tried with no modules and with the ssd out as well, it still won’t get me to the bios screen.

Also yeah I was looking at those codes, since it seems to say something about the CPU I’m pretty sure it was DOA :-/ I have a ticket with support so we’ll see how long it takes to get a replacement board.

Hopefully support has some trick up their sleeves. Good luck!

Did you give it enough time to do the memory training. You get a blank screen until it’s done I believe.

@pyro how long did you let it sit running? Mine did something somewhat similar the very first time I turned it on.

I’m not turning it off, it turns itself off. I press the button then spam the f2 key to get to the bios and the light on the power button eventually turns off and I start getting the diagnostic LED blinks on either side of the laptop. The LEDs seem to suggest a CPU issue.

I’m not stopping the boot process its doing that on its own.

1 Like

For folks referring back to this thread in the future, we’ve found a workaround for this which we’ve posted at the end of the Knowledge Base article here: My Framework Laptop is not powering on


After 5 wonderful months, my DIY edition has suddenly stopped booting. The power button light turns on briefly and turns right back off. LEDs on the side give orange error codes for “cpu deassert sleep s4” and “cpu reached s0 state”, identical to OP’s first post. No fanspin. I have tried mainboard reset instructions from the knowledgebase a couple of times now, but no luck. I’m not sure how a mainboard can die this way without warning. Waiting for support to get back to me. :crossed_fingers:

Happy to report that after the 3rd try my DIY did wake up and said hi.

Framework Support is awesome. :pray: (IDK what timezone they work in because they respond right away to emails!)

I’m happy that it’s working (but there’s a small part of me that’s sad because I don’t get to do the “fun stuff” i.e. replacing the motherboard! JK :smiley: )

Anyway, I’m still curious to know the root cause for this issue. I’ll share another update here if I find one.

After the third attempt of resetting the mainboard, my laptop now boots up provided no expansion cards are plugged in. If I plug all four expansion cards in, I get the same error code as the OP. (As far as I can tell, it doesn’t matter which expansion cards or which locations.)

I’m sorry to hear that you are having issues with your laptop, Atul. Please just know that you are in great hands with our support team :orange_heart:


This may be a naive question: Do I need to re-install OSs from scratch after the mainboard is replaced?

No, you will not need to reinstall.

Microsoft typically allows you to replace three components without having to re-activate or relicense.

An operating system typically only needs a reinstall when switching southbridge chipsets, the most extreme example being switching from an Intel motherboard to an AMD motherboard. If the motherboard is the same model and thus has the same southbridge chipset, then no reinstall will be required.

Linux is the most resilient to motherboard swaps, rarely requiring a reinstallation of the OS.

1 Like

I have not yet run into an issue where I had to replace a motherboard on a BitLocker encrypted system.

I’m thinking that you would just download the BitLocker key from your Microsoft account (MSA) to a file on USB drive so it could be imported into the new TPM module.

Mainboard replacement went smoothly! However I’m no longer seeing a grub menu to boot into Manjaro. Goes straight to Win10. I guess I’ll have to boot off a live USB and update-grub or something. Help, Google!

I was able to restore my dual-boot Manjaro+Win10 by following the instructions in this video: Manjaro: recover GRUB after a Windows Update - YouTube
Life is back to normal!