Framework 13 AMD 7640U graphic performance

Hi,

I am on vacation and tried the GPU performance. I compared my framework to my Thinkpad p14s gen2 amd (5850u) in 3dmark, and indeed, got about twice the performance with the 7640u.
However trying to play world of warcraft classic (not very new, not very gpu intensive game that usually works well on igpus) about every couple minutes I gte a freeze, caps lock LED is not responsive either, about 8-10 seconds later scree flashes a couple of times and restarts working. I had an external monitor connected and that gets disconnected with this.
I installed the recommended driver pack. After I also tried to install a driver downloaded from AMD (a generic tool that recogtnizes and installs what you need) to rensure it’s latest. Still the issue persists. Plus, performance feels laggy somehow, even though FPS counter shows 60 FPS, it feels like lower fps somehow.
Compared to my thinkpad that one feels more snappy and doesn’t have the issues. I believe that one has the Vega 8 gpu chip.
Does anyone has any idea, I wonder if this is application specific (I don’t think so talking about a widely supported old software, but it may be), or are drivers this immature? I wonder if it’s a matter of just waiting and watching out for AMD new driver releases or maybe try something else.
I am using win11 as it was recommended to have best support for this amd platform.

Which Bios version are you using?
The first batches were shipped with an older version. The new version fixes a lot of bugs.

WoW Classic has had a lot of graphics bodging done over the years. Weird advanced options might be causing issues. Does the current client for WoW (or WoW Starter Edition, if you don’t want to sub) have the same issues?

Have you try with other games ? It’s only wow ?

Bios is the 3.03 so should be fine, was first thing I checked after I booted it the other day.
I don’t know if this persists as I don’t play the other versions to be honest. Can try playing something indeed.
I don’t really play anything else atm, plaed Starfield recently but that’s not something worht starting up on this hardware :slight_smile:
I would have thought its something old that works on my 6650xt, on my 6900xt (desktop AMD gpus), also on my ryzen 7 5850u fine so it is probably related to this specific cpu / igp, but if graphic problems is not soemthing others have then it could be indeed just application specific (still weird ofc). I will try to do soem more tests.

AMD graphics drivers are pretty bad right now for these APUs, at least in my experience.

Have you tried the BIOS setting to reserve 4GB to iGPU (UMA_Game_Optimized or something like that)? I assume you have 2 sticks of SO-DIMM?

3 Likes

That’s a good point, didn’t see the option. Will do some tests with it enabled as well thanks. Typical demo scenario, yesterday (before seeing this) I tried for 15m and driver didn’t crash anymore, but it happened previously like 6 or 8 times so I’m sure I will have more opportunities to see. :slight_smile: yes I have 2 x 16Gb ddr5 5600 so plenty of ram.

I have set the above option in BIOS. Yesterday I played for about 2 hours without any incident. Today I had 2 in about half an hour.
I do see an Eventid 4011 with source Display that reads: “Display driver amdwddmg stopped responding and has successfully recovered.”
About one minute later a 4109:
“Application WowClassic.exe has been blocked from accessing Graphics hardware.”
I will have to try and play something else, however the issue has been quite intermittent which makes it non trivial to replicate. I am now trying to determine if this has to do with second monitor connected or not and will try with and without.
Problem is machine goes unresponsive, now past 2 times I waited about a minute and image never came back. I heard music in the background, but I could also not shut down by a simple power button press, had to force poweroff with holding power button.
p.s. performance seems to work just fine now, possibly due to the BIOS setting. It’s just the video driver crash that is a problem.

Have you try to reinstall the gpu drivers? I’ve played a bit on my amd framework. Never had any issues

Tried all, setting game to directx 11 legacy solved it. Maybe a later driver resolves the issues, will try if a new driver version pops up. So far so good, otherwise seems to work well, also no issues with the connected monitor since then.