Framework 13 AMD 7840U USB-C Monitor does not work


I recently purchased this monitor:
I attempted to use it over USB-C, but it is not receiving any signal. It powers up, but goes to sleep after a few minutes. I’ve tried all 4 ports, but the issue persists. Interestingly, when I connected the monitor to my desktop PC via USB-C, it worked without any problems.
Do you have any ideas on how I can resolve this issue?
My system is running Windows 11 with the latest updates, and I have 64GB of RAM and the latest BIOS as well.

Thank you!

Are you connecting it to the right port? Don’t use port 2.

Also you may want to rearrange how power is being delivered to both the FW13 and the monitor. What’s worked for others is to power the FW13 over one port and connect the monitor to another. Or connect the power supply to the monitor and then to the FW13.


I tried all the ports, but all are the same. I also ordered a new USB-C 4 cable but that didn’t help either. If I power the monitor with an external power source it works but this is not a good solution.