DisplayPort over USB-C not working (AMD 13)

I have a new AMD 13" running on Windows 11 Pro, BIOS 3.03, 4TB SSD, 64GB RAM, running the latest version of windows and all the Driver updates direct from Framework.

Everything works great, except for when I try to connect the Framework to my monitor (Dell U3219Q) by USB-C. No signal is detected by the monitor, however all the USB devices are detected and work (Keyboard/Mouse).

I have 2 USB-C expansion cards, and I tried connecting the monitor through both of expansion cards on ports 1 & 3. Neither configuration worked.

Interestingly enough, I also have a DisplayPort expansion card, which does detect the monitor and works correctly. I should also note I have had no issue using DisplayPort over USB-C with this monitor with other devices.

Any ideas on what might be going on here? Might it just be that I have 2 bad USB-C cards? Maybe its a driver issue? Perhaps a hardware issue? Any help or suggestions would be appreciated. Thanks!

I had to fiddle a setting in the monitor (Samsung ultrawide, with LAN/Audio hub) at work that said something along the lines of 'Support Resolution over Bandwidth Rate" or something to that effect.

The monitor obviously has a hub multiplex inside it - so that’s likely the problem - will depend on how the vendor has integrated it for that particular display.

Also you can try just connecting directly into the Mobo USB-C (sans the slot adaptor) and seeing if you get different behaviour.

I have the same, I wont say problem, but funky behavior. AMD 13, and it wont take a YODOIT portable panle through USB C but fine powering with USB and display through HDMI, strangly with a cheap USB hub i got for a I pad on it, it will do all through USB and split to HDMI in the HUB so it seem like the panle is not happy with output of the USB rather than the USB wont do it, Unfortunatly no settings in the panle for changing input settings so i think im stuck with 2 cables. (work out the back of a van on farms so portable disply is handy compared to a proper monitor.)

Interesting. Can you try this?
Power the portable monitor through other means first, and after making sure it is powered up, connect it to the Framework using USB-C. I know it defeats the “single USB-C cable” convenience, but I’m wondering if it behaves like my CNBANAN portable monitor (14" 2160x1440 3:2 IPS).

Same as you, my CNBANAN won’t display anything when connected using a single USB-C cable. But if I power it up first, and then connect it to Framework, it works. It even works if I use two USB-C cables to Framework, first one to just power it, and then second one to do DP. Stupid, I know.

It also works fine through HDMI, even going through a cheap UGREEN Revodok 5-in-1 USB-C Hub with HDMI.

I guess DP Alt-Mode negotiation is “hard” to get right. My guess is that the monitor needs to be fully powered up to negotiate DP Alt-Mode with Framework. Considering the monitor apparently works fine with many other devices, I’m 50/50 split on whose firmware is broken.

Funny thing is, my Cocopar 15.6" FHD portable monitor works with anything I throw at it, including Framework. I guess some companies just do DP Alt-Mode better, or maybe they talk slightly different languages :wink: Communication is hard.

2 Likes

I am also pretty sure there is something a bit screwy there.

My usb-c portable display works fine on all 3 ports but some of my basic usb-c to dp adabters don’t produce output, unless I put an mst hub between it and the display.

I had used a USB-C cable to charge another notebook from my monitor without display output and just assumed it would work for display output too since 65W charging did. I was wrong. After searching for the cable that came with the monitor it works perfectly now :sweat_smile: So maybe try to validate your cable can do what you ask for.

3 Likes

I also have the same problem since this morning!
It worked fine until yesterday, though…

1 Like

Very intresting, i wasnt expecting it but works perfectly, USB A for power, and USB C for image, works perfectly, it seems to be a power suply and image issue over the same port, that then begs the question why it works over one USB C through a hub spliting it to USB C for power and HDMI for image?

Still 2 cables but USB is a far more versatile cable compaired to one USB C and one HDMI to mini HDMI (not very flexable), and at least i can carry one more USB C To get rid of the HDMI and get some longer conection lines! Thanks.

1 Like

My i pad powers and dose display straight out the USB C port on the pannle, again usefull for work but not as powerfull as a laptop and only mirrors screen, not the most usefull hence having a hub so i can use mouse and keyboard with it. and cable with the screen works on my desktop and a workfrends laptop so cable and display work over USB C only, just the framwork has a issue with it, and as above only with power and image delivery over the same port, rather strange?

Just a thought: considering how there are some power negotiation issues with 5V power adapters and the external displays working if not powered by the laptop, maybe there is some relation there?

What happens if you pull out your USB-A cable after connection/image via USB-C has been established @Jonathan_Dixon @Richard_Lee1 ?

1 Like

Just tryed it, it shuts down the screen, so definetly seems like the USB C dosent like suplying power and Display at the same time. with just USB c conected the display powers up and then goes to slepp as its only getting power and no display feed, like the USB C slot can only do one at a time and reverts to power rather than display. the only other adapter ive had a problem with is a cheap work dongle in the office at work that only converts USB C to two HDMI and again the displays wake but dont show as displays, even though thay are poweerd by mains, its like that dongle needs power and display from the USB C and only gets power. seems odd as my usual hub gets power from the USB C, and can work USB A + USB C data, a card reader and HDMI out without needing any other power in. but having just tryed it it will only do display out on HDMI not USB C.

I also wounder if ive just found a infinet power loop! playing about with it, i tryed powering my hub from my spair USB C on the laptop, and ive found the charging light comes on and laptop says its charging! UNLIMITED POWER!!! (i know thats not how it works, but quite amusing).

2 Likes

I tried that early on, and it doesn’t work. Also, my cables aren’t the problem. I’ve some high quality cables and swapping them didn’t make a difference. And they work fine with my other portable monitor.

2 Likes

Just reporting back to the group that I bought a USB4 cable from Amazon, to test instead of the cable that came with the monitor (which claimed to be Thunderbolt). The connection worked - Success.

So my issue was indeed a cable compatibility. If anyone else is having the same problem, I would recommend buying a cable that specifically states USB4 on it (or Thunderbolt 4).

4 Likes