Framework 13 AMD Ryzen - crashing every 5 minutes on Windows 11 22H2

I have installed Windows 11 twice and cannot stop the laptop from rebooting every 5 minutes or so. Event Viewer shows: “Windows boot environment failed load the HSP firmware. StatusCode: {File Not Found}
The file %hs does not exist., Reason: Failed to detect HSP device”. --along with “Dump file creation failed due to error during dump creation.”

Web search returns very little. I have updated the BIOS to 3.0.3. The Framework drivers have been installed as well. Any suggestions or insights appreciated.

1 Like

It turns out that AMD has additional drivers, available via
In my case (also Laptop 13 DIY and Windows) that lead to the AMD software installing some 5 extra drivers.


Rhoberto, thank you for the suggestion. Ran the AMD updater tool, rebooted, and haven’t had an issue since. Thanks again!


@TheTwistgibber, would Framework consider updating the AMD driver bundle to provide better initial stability? Especially because there’s still so many batches of upcoming new AMD users… (to minimize the dependency of them keeping track on forum threads and / or number of support tickets)

I had the same random reboots until I used the “AMD autodetect” driver tool.
GPU and the platform drivers got updated, I think everyone should install the AMD Updates after using the framework bundle!

Hi everyone. This has been reported/escalated to the Firmware/Software group for review. We’re glad that the AMD tool was able to pull down the updates to improve stability, and we’ll provide an update once our team has had the opportunity to dig in.

For what it’s worth, there’s a new GPU driver from AMD as of yesterday (11/2). This seemed to have helped stability for me as well.

Tried updating through AMD and it fixed all of my issues. As of 11/4


I’'m having the same problem, but have downloaded and run the adrenaline pack 23.11.1 from AMD. Any other ideas? I have a BSOD every 15mins or so, and unfortunately the dump file is not written out.

Chipsets->Laptop Chipsets->AMD Ryzen and Athlon Mobile (Chipset)
Mine has been running beautifully for some time now.

Or as others have mentioned, just grab the “Auto-Detect and Install Driver Updates for AMD Radeon™ Series Graphics and Ryzen™ Chipsets” and let it do its thing.

Thanks. The Auto-Detect and Install Driver updates download is essentially the adrenaline package. I have however tried installing just the Chipset drivers. Let’s see how that goes!

Ok - still having the blue screens, but noticed that it is only on battery. As there is no crash dump being created, I wonder if the PCIE power handling is causing the problem (no volume mounted anymore, so SSD is disappearing). I have changed the PCIE power management from “Maximum” to “Moderate”. Will see if this helps.

It turns out that the issue I had was related to a connector cable not being seated properly. Despite the issue not being related to that cable, reconnecting the cable solved my issue. Moreover, it was stronger when not on battery.

Have you checked all cables and connectors?

Thanks for the hints. I did indeed check the cables - all seems OK.

In fact, I think I can replicate (and eliminate) the BSODs. Basically, they only happen on battery and when the PCI Express Link State Management is set to Maximum Power Savings on battery. If I change the setting to Moderate, then I get no BSOD. I will also post this finding on the other posts in Community Support.


I’m still having issues but as @sgilderd said I have changed my pcie link state power management to match what I was running plugged in, where there weren’t issues and as of 3 hours ago i haven’t had a crash. Fingers crossed this is the fix but I will report back if I crash again

forgot to reply but i crashed like 7 hours later.

I thought it was an issue with my framework. I was trying to diagnose the fault but it would just randomly freeze up, not even under load or using much of the systems resources. It was very confusing. In the end just searching up the error from event viewer brought me to this thread which was instantly reassuring! Had I had known it was a bigger issue I would’ve gone straight here! Thanks for the help.

I’m having hard locks - video freezes as-is, without generating any error messages anywhere. I have to power cycle when this happens. Seems to occur primarily on battery. Is this the same problem as described here? I found this thread via the mysterious HSP firmware message.

same here - sometimes BSOD, I can see events in event viewer - as per this thread, sometimes just freezes and eventually recovers with no errors, no crash, etc.

Very frustrating.
So far, seen it on battery only, but will continue to test

@Toby_Cook @zbrozek This thread might be relevant, lots of us dealing with the same issue.