AMD 7040 13 - BSOD Issues Out of the Box

So I just got the AMD Framework 13 DIY and am having BSODs in Windows 11 out of the box. I tried installing the driver bundle from Framework but every time I install, the computer will BSOD with an error “CRITICAL PROCESS DIED”. It looks like it is getting to the fingerprint driver when it goes to a BSOD.

Anyone seen anything like this?

Did you run a memtest? If not, get a bootable ISO from and flash it to an USB stick. Let it run for at least 1 pass.

I ran memtest for 1 pass and was given a PASS rating by memtest. It’s actually still running and the memory is still looking good. Any other thoughts?

What are your memory specs?

I’m using a G.Skill Ripjaws DDR5 5600 16GBx2 configuration (CL40-40-40-89).

Mine had a couple of crashes and freezes before I got all the drivers installed, but has been fairly stable since*.

I did:

  1. Fresh install of Windows 11
  2. Let it update everything it could through windows update
  3. Install the driver bundle from Framework
  4. Run AMD’s driver installation tool, which updated a couple of things

Maybe you should try steps 2 and 4 first?

* There was one time when I thought I had put the laptop to sleep, but when I turned it on later, it did a fresh boot with nothing opened. I think it crashed and rebooted, but it’s possible that windows just installed an update and rebooted without asking me or something dumb like that.

So I was able to get everything working by taking Nathan’s advice. The only thing I did differently this time was to install drivers from Windows Update and AMD first before ever running the Framework driver installer. Thanks to everyone who gave troubleshooting ideas!

Ugh, now I have had a BSOD - I was just scrolling a web page in Firefox with nothing else opened and it froze (even the mouse pointer stopped moving) and then it blue screened and then rebooted.

I had just gotten the Windows “low battery” warning (20%?) a minute earlier and was trying to finish reading something before getting a charger.

This is the first time I’ve seen that warning and the first time I’ve seen a BSOD, so perhaps they’re related.

The AMD crash reporter came up after it rebooted, but the first question it asked me was “which AMD component crashed?”, which seems like something it should know better than me. I guessed the chipset/platform driver just so that I could submit it.

I’m having the same issue. Could it be because of the RAM? @Nathan_Friedly Is your ram also G.Skill Ripjaws DDR5 5600 16GBx2 configuration (CL40-40-40-89) because that is mine and I am also having the same thing, mouse freeze blue screen.

No, I got my RAM from Framework with the laptop, because I read about issues other people had with other RAM sticks. It had a Framework sticker on the RAM, but it looks like it’s actually from A-Data with SK Hynix chips: