Framework 13th Gen Intel - Mainboard issue?

I already submitted a support request for this but thought I would post here while I wait for a response from Framework in case anyone had any ideas.
Starting yesterday, my Framework 13 13th Gen Intel started hanging on shutdown - after windows stopped and the screen went black the system stayed powered on and hung. Eventually you just have to press an hold the power button until it forces a shutdown. I also started seeing that it would take forever (45-60 seconds or more) for the Framework logo to appear when booting up.
Figuring that this was a messed up Windows update, I rolled back the monthly patches. After that didn’t work, I decided to do a fresh install of Windows 11.
This is where it gets even stranger. I can’t connect a drive or a dock or anything other than a charging cable to the USB-C module (any of them) and have it work. I made a Windows 11 drive on another laptop (my work Dell machine) and confirmed I could boot to it on that machine.
However, the Framework doesn’t see it in Windows or in the F12 boot menu.
I tried loading the firmware defaults just in case but it didn’t change anything.
Thinking that maybe it was getting stuck because of a memory issue I tried running on one of the 2 memory modules, each of them by themselves, and that didn’t change anything either.
Does anyone have any other suggestions?

Hi and welcome

Reset BIOS to default.
Try removing all the expansion cards and power on
Try a full mainboard reset.
Try maybe booting from a live Ubuntu USB to ensure it is not Windows related.

1 Like

I’ve already tried removing all cards and powering on. I have also reset BIOS.
What is a “full mainboard reset” and how do I do that?
Edit: I found the article for that, not sure if it applies since my computer does eventually power on, but I will give that a try.

1 Like

Have you installed the Driver bundle?

You’re likely not going to see the external storage devices in F12 menu unless you first disable secure boot.

What expansion cards do you have in your four slots. I suggest unplugging all except for a single USB C first as a test. Then go from there.

Thanks, yes, I have tried to unplug everything and actually tried plugging my dock and a USB-C drive into the port directly to see if it was the expansion card. No luck there either. All of mine are USB-C although I do have a few others that I guess I could try e.g. see if the ethernet or HDMI ones work…
I do have the driver bundle installed, and everything had been working fine up until yesterday.
I will try to disable secure boot, but even on my work machine with secure boot enabled the Windows 11 install media shows up so I didn’t think that would be an issue.

Hi @Peter_Bossley,

As others have suggested you might need to reset your Mainboard if something is corrupt in your embedded controller? I am trying to think if resetting the BIOS actually doesn’t reset all the sublevel components like the embedded controller. Flashing the mainboard is the closest thing to the factory fresh state.

Get a copy of your Bitlocker key though before you do that if you still need access to your existing Windows installation.

If the issues persists after resetting the mainboard and booting to something like the Ubuntu LIVE USB drive then I would point it to something hardware releated.

Lots of subsystems on that board and one of them could be causing the hangup and resultant ports not seeing drives plugged into them.

1 Like

I found a topic where a few others seem to be having identical issues (except my keyboard still works.)
So it is sounding like there is some kind of hardware issue going around maybe?

Just an update, Framework is sending me a new system board. I wonder since this is happening to a few of us if there is a larger longevity issue at play here though? Very curious what the actual cause of this could be.

1 Like

Hi @Peter_Bossley,

Glad to hear they are sending you a new mainboard. Sometimes one of many sub components of the mainboard can be causing the hang. Engineering likely wants to take a look and get more data points to narrow down if it is hardware or firmware related. So many things it could be and without a console/debugging output it is hard to narrow down where the issue(s) are.

Update: the replacement system board resolved this problem. I hope I can get an explanation as to what caused this, though.

Glad to hear the new board solved the issue!