Framework 13 (12th gen) Won't Boot

Hi, I was on my Framework 13 (12th gen, Win 11) this afternoon. I stepped away for a few minutes and came back to a black, nonresponsive screen. I’ve been having problems on and off since I bought the laptop a year ago with the laptop getting super hot with nothing even running on it, and it was this way in the morning today (thought it ran fine in the morning). Anyway, upon rebooting, it now gets stuck on the Framework splash screen with the circular logo that spins (it stops spinning after a few seconds). When I power it down and try to reboot, it alternates between getting stuck on the plain Framework splash screen, or with the same screen but a message at the bottom, “Preparing Automatic Repair”, which also gets stuck.

I’ve tried the following:

  • Unseating the SSD and RAM, and disconnecting the battery cable and the circular lithium battery, leaving in this state for a few minutes, then connecting a power cable, which is apparently supposed to reset the main board. No effect.
  • Creating a USB boot drive. The laptop still gets stuck on the Framework splash screen. It doesn’t seem to pick up the USB drive at all.

Any suggestions would be great. I am supposed to fly out to Denmark for 3 weeks in 2 days and of course the whole Framework company has an event in these two days and aren’t responding to tickets.

Have you tried a new nvme drive? Also, are you able to get into the BIOS?

I don’t have a spare nvme to test with. And I’m unable to get to the BIOS.

Have you tried booting without the ssd? It should force you into the BIOS or at least prompt you to install a ssd. If that works, then there may be a problem with your ssd.

1 Like

When I take the SSD out and power on, it brings up a boot menu. When I plug in my Windows media USB, it seems like it’s able to load from there. It prompts about installing Windows.

Would there be any way to recover the files off that SSD and then reinstall Windows onto that drive?

Assuming you don’t have bitlocker enabled, you can put the ssd into a nvme enclosure and recover the files using another computer. There’s also the option to try and repair the Windows installation using the Windows installer.

I have actually been able to get into the UEFI and BIOS to set up a boot order going first to the USB drive with the Windows media, and then second to the SSD. However, once I have the SSD connected, it doesn’t seem to load the Windows media stuff from the USB drive, even if it’s the first priority in the boot order. I still get stuck on the Framework splash screen. With the SSD taken out, I get the Windows media install options from the USB drive. In the repair options for Windows from the USB drive, none of them work (granted, the SSD is not connected when I’m trying these options).

What would this indicate?

I think the bootloader is automatically trying to switch the boot order as it detects that the SSD has an OS installed. I think the best option is to first recover important files from the SSD, wipe it, then reinstall Windows.

I just picked up an nvme adapter for my ssd to test out on another laptop, and the drive doesn’t even appear on the other laptop (it is bitlocked, but I believe it should still show up). Seems like the drive is screwed? I was hoping to at least see what files that were on it that might not have been backed up before attempting to format it.

Indeed, the SSD seems fried. Even if Bitlocker was enabled, the drive should still show up and prompt you for a password to unlock it.

Thanks for all your help in this issue. One last question: do you have any suggestions on how to format this drive if I can’t get it to appear in an nvme reader on another laptop? I can no longer get to the BIOS when I put the drive into my framework laptop.

Oh, if you can’t format this drive even after putting it into another laptop using a nvme reader, the drive is completely dead. That will need to be RMA’d.

In my experience Linux has been great for recovering files off an unstable/dying drive or confirming that it is indeed dead before giving up. Perhaps boot into a live environment then check if sudo fdisk -l shows it through the external adapter at some point while you’re doing RMA?