Framework 16 battery stopped working, won't boot without ac

I tried to boot my laptop today but it seems like it no longer works with the battery alone. The laptop is able to boot if i have the ac hooked up to one of the 4 charging enabled ports, but no amount of charging is actually happening on the battery. I’ve tried multiple cables and charging sources, as well as multiple usb-c modules. The charging led on either side glows white as if the battery was already charged and the OS shows the battery is currently at 98%, but pulling the plug causes an immediate power off. At one point, I thought it may have to do with the charging cutoff, but setting that to 80% actually caused the laptop to start shutting down before posting to bios, presumably because the power on the battery was detected as being higher than that. I was only able to get back into the bios by disconnecting the battery and booting with the battery completely removed, and after setting it back to 100% it seems to at least function with the ac adapter again.

I’ve tried reinstalling the bios (3.03 on the ryzen 7840HS) and I’ve also tried enabling “Power on AC Attach”, which actually doesn’t appear to do anything. I’ve tried every permutation of standalone operation/detection, enabling and disabling the PCIE power management, and changing the input power modules setting as well as a handful of different module permutations. Trying different power outlets didn’t appear to help either. From what I can tell this is an issue unrelated to the OS, but I am running fedora silverblue on it if that matters at all and I have tried rolling back to previous updates without any success.

This feels to me like an issue with a part of the motherboard that would control how the battery is calibrated, but I’m not sure how or if I can access that or reset it. It seems like the framework 13 has a cmos battery that can be popped out to reset whatever controller handles this, but I wasn’t able to find anything like that on the 16. If that’s just built into the battery, taking the whole thing out for a few minutes didn’t seem to help. Has anyone else run into this problem or been able to solve it? I’ve seen a handful of threads about this both on here and reddit, but none of them seem to have any conclusive solution that worked.

EDIT: also as a note, i’ve been using the laptop successfully for about a month without any issue. I can’t really think of any behavior I changed that would have resulted in this happening.

This might really be a mainboard issue, BUT have you checked the battery connection? Be careful, but unseat it and then reseat it. See if this fixes the problem.

If this doesn’t, then I would very much recommend that you contact customer support about this. They will get you squared away!

I did try reseating it 3-4 times when I was trying to resolve the charging cutoff issue, so I’m pretty sure it hasn’t had any effect. I have reached out to customer support though, so hopefully they can recommend something too

EDIT: I tried reseating again just to be sure, but unfortunately it didnt appear to help

Have you looked at the connector to see if there are any bent pins? With the number of times you have reset the connector it would be good to rule this out.

Yeah, I double checked it in the last reseating and they all look straight. I will say the issue started before I ever took the battery out so I dont think its related to the pins deforming.

I also tried booting again without the battery and a number of other things to try and get the motherboard to reset its state on the battery, holding the power button down to drain the mobo power (i was able to see the bios clock go to 00:00 so I believe it reset), disconnecting the battery via bios again, turning down the charge cutoff from 100 to 99 to 98, at which point the laptop stops booting since it recognizes the battery as having 98% charge but doesn’t seem to be able to use that charge. I’ve also noticed that games perform very poorly at the moment (closer to igpu speed) but I don’t know if it’s actually related and I probably wont test it thoroughly because im more concerned with the battery. I still haven’t heard back from the support ticket but my guess at this point is that it’s gonna be hardware related which is pretty bizarre considering i’ve not seen any issue up to this point. The only thing I can think that I did differently prior to the issue was play a game for a few hours, which I hadn’t done before on the device yet.

EDIT: just to test everything i can think of, i’ve also tried reseating the ram, moving the ram to the second slot, swapping the pcie graphics module with the pcie fan module, using the 240w usb-c cable with a different power brick, using the same power brick with a different usb-c cable, reconnecting all the expansion ports to the configuration it was in when it stopped working initially, monitoring battery usage through the sensors (reported as 17.685v and 0a). The only thing I haven’t tried is a multimeter, but at this point, I’m just filling time while I wait for the support team to email me back.

I’m still in talks with the support team and my ticket has been escalated, but since I’ve seen a handful of other people with a similar problem and I haven’t seen any framework 16 specific help technical help documents like there are for the framework 13, I wanted to list some of the things I suspected about the mainboard that were also confirmed by the support team:

  1. The mainboard has a reset procedure that requires you plug in the charger and depress the chassis intrusion switch for 2 seconds, release for 2 seconds and repeat 10x. My switch was between the battery and the ram just next to the heatsink warning. It looks like a small black arm poking up from a metal square and pressing it down caused my led to go back to normal as though the baseplate had been attached and releasing causes the red light to blink. There are documents of this applying to the framework 13, but I was able to see it reset here by watching the linux audio compatibility option switch to windows.

  2. There is a power drain procedure that I had suspected given some documents related to the framework 13, but I can confirm that if you detatch the modules, ram, ssd, and battery and then hold the power button for 15 seconds, this will cause the mainboard to drain it’s internal battery and this results in a bios reset. Considering there is no cmos to remove on the framework 16, this is very useful information imo.

These are two things I attempted prior to the support team responding and I didnt have any luck with either, but when I tried them I was just guessing based on info available for the framework 13. Unfortunately trying them again did not solve the issue, but for anyone else trying to troubleshoot a similar issue this can be your confirmation on the procedure until better support documentation is available for the framework 16. I appreciate the community and support team trying to help with this issue and look forward to getting it resolved.

Final update hopefully, framework support determined my motherboard was bad and are sending a new one.

Bumping again,

I successfully replaced my old mainboard with the new mainboard, but unfortunately it does not seem to have solved the problem. I have noticed that the device now shows “charging” as the battery status in the operating system and in the LED charging indicator, but the battery itself has not budged on percentage and will not power the machine on it’s own. I reached out to the support team again in the same email thread, but since it’s been ~2 weeks since our last correspondence I’m worried the support ticket might have been closed. Does anyone know if I should be opening a separate support ticket to go through the process again? As much as I appreciate support being so thorough in their tests, I’m really hoping to be able to shortcut the 2 weeks of back and forth testing on the machine since it’s already been deemed a hardware issue.