[SOLVED] Framework 16 Ryzen 9 Won't charge

After assembling my FW16 DIY I plugged it in, installed Linux, and used it for several hours. During this period the battery charged just fine. The next day I woke it from suspend to find the battery very low, and no charging was happening despite being plugged in. I tried several chargers in both expansion ports 1 and 4 (the ones indicated to support charging) all with the same result: the associated LED would light up amber briefly, then shut off, and the OS would not recognize any power flowing. Eventually the laptop shut off due to low battery. Here’s where things get more odd: at this point plugging in a USB C cable resulted in the amber charge LED lighting up solid for several hours, at which point it turned off entirely and would not light up again at all when unplugging/replugging the device. Turning the device on, however, resulted in the original behavior of the LED lighting briefly before turning off, and when booted showed that the batter was still very low on charge, so much so that the laptop shut off on its own again shortly afterwards. This again resulted in a solid amber light for a few hours, but no apparent change to battery status, as attempting to boot now results in the screen lighting up, a very short view of the BIOS password input screen, and then the device losing power.
So far I’ve tried:

  1. Both charging-capable expansion ports, 1 and 4, with and without expansion cards in them
  2. Two high-power USB C cables that I use to charge other laptops, and a low-power USB A-to-C cable overnight
  3. Removing the battery for a few minutes and then reassembling the laptop

None have changed any of the observed behavior. I’ll restate that charging was working upon receipt of the device, and even after charging stopped working the device remained able to discharge power from the battery to operate.

Sorry that you are having issues. FYI, all of the ports support charging: Expansion Card Slot functionality on Framework Laptop 16

Maybe try resetting the mainboard and/or resetting the bios to defaults? I’ll add a link to the reset procedure when I find it. This is for the 13", might be the same for the 16": Reset forgotten BIOS password - #20 by pkunk

Are you using a Framework charger?

There’s a procedure that seems to solve a lot of odd hardware-related problems. I’d suggest trying that.

If you do, please report back whether it fixed the problem or not. I’m trying to compile a list of the problems it can correct.

I can’t get into the BIOS for long enough on battery power to select the option to disconnect the battery, so I’ve physically removed it. I’m not able now to start the system while the batter is removed; plugging it into power results in flashing red and blue LEDs, and hitting the power button makes its white LED light up briefly before turning off. There’s no other indication of the system even trying to boot (no screen backlight or fans).

Now that the power has been completely drained from the motherboard, it should be safe to reconnect the battery and attempt to start it up again.

I am not, no, I didn’t get one. The cable I’m using came with a Macbook and seems to do some sort of USB PD, and it’s plugged into an adapter from another party. What I can report is that this arrangement seems to work for a few other laptops, phones, and tablets, and this very FW 16 laptop just the other day when I first unboxed it. Additionally I’ve tried another totally separate charger setup that also works for all my other devices.

Well, that sure seems to have done something! The laptop is now powering on and charging! Thanks for the help.