Framework 16 inch will not post

I recently purchased a 16. I installed Windows 10 and the driver pack. everything was working. I then installed the 3.03 bios and since I have not been able to get it to post. I have 2 sticks of 32 gbs ddr5 5600 RAM I have tried each individual stick in each slot and have not had any luck.

Also If I run it for a while without posting the fans come on.

Edit: is there a way to reset the BIOS on the 16? I have only found a guide to reset the 13.
Has anyone had a similar experience?

Interesting that it won’t post after the bios update. Could you provide the following so the community might be able to help you more:
What’s the SKU/model number of your ram kit?
Does the charging LED indicator flash a green/red(orange)/blue byte-code within the first 2 minutes of boot? If so what’s the pattern?
Do you have a RGB Macropad? If so, does it light up within 10 seconds of pressing the power button?

I got the RAM from framework. Not sure what the sku is but its got the P/N: AD5S560032G-SW.
The blink code I get is: G-G-G-G-G-G-G-G-G-G-G-G-(orange or red not sure)-G-G-G-G-G-G-G.

No macropad.

I have tried both sticks of RAM individually in slot 1.

I have also tried pressing the little switch inside 10 times to reset the main board a couple times but to no avail. I did this will all input models removed except for one USB-C for power.

I then also tried putting an hdmi in and seeing if an external monitor would help.

Caps lock and keyboard lights do not come on either. Only the power button light and the charging/diagnostic LED.

@Theo_Zinner
With so much green your BIOS thinks its OK. It thinks RAM, Display, CPU etc. is all OK.
The “Orange” is just a separator between the first 12 flashes, and the last 8 flashes.
The first 12 are RED or GREEN, the last 8 are BLUE or GREEN.

I would suggest plugging in an external display via an HDMI or DP expansion card, and see if you get any output on that.
My guess is the display is reporting its all OK, when in fact something is wrong there, thus my suggestion to plug in an external display.

I already tried this. It didn’t seem to help.

I just did a bit of a test on my FW16.
I tried with a HDMI display and also a DP display.
On first boot, even if you press F2 to get into the BIOS, the BIOS display only appears on the Laptop display, not the external display.
The Linux grub boot menu is also only on the Laptop display, not the external one.
The Linux whole disk encryption password is only on the Laptop display, not the external one.
Only when you get to the Linux Desktop Login page does the external display come out of standby more and display something.

In Summary, I don’t know how to diagnose this, apart form mentioning that your GGG etc. list should have 8 Gs at the end, and not the 7 you put in your message above.

There are probably other diagnostic steps to try, but I have never done them before myself so would not like to recommend them to others.

I guess the only thing to try is the main board reset procedure.
Do you know how to do that?

I unplugged all the modules except the AC power and pressed the little switch ten times for 2 seconds which supposedly is it. Is there anything you think I missed?

Note: The following instructions are cut/pasted from a FW support email to me when they were helping me with something.
Instructions for Framework 16 main board reset:
Please try the following steps and see if it helps.

A. Set the BIOS to default by tapping F2 or F12 during the boot-up, once in the BIOS, please press F9 and F10.

B. If the issue persists, please reset the mainboard using the guide below.

  1. Please turn off the laptop and unplug the charger.

  2. Remove the input module, touchpad module, spacers, and Mid Plate, then plug in the charger.

  3. Slowly press the chassis open switch/case switch 10 times, holding each press for 2 seconds. Release, wait for the red blink on the mainboard LED, then repeat this step.

Please see the location of the chassis open switch for reference.
chassis-open-switch

  1. Press the power button to boot the system.
1 Like

I already tried this. When you did it was there any indication that it worked?

When I did this, there was no indication it had worked. I.e. no LED going a different colour if it worked, that sort of thing.
I think the only thing different from what you describe, is that you start with the power unplugged and all expansion slots unplugged. (Except the one USB-C you need to plug the power in).
Then you plug the power in and start the process of pressing the chassis open switch.

I think you will have to take this up with FW support.
My guess is the BIOS update procedure did not work correctly and as a result it has been left in some odd state.

Thanks for your help. That is what I am thinking to. I just haven’t heard back yet and want to make sure I have done everything I can. I emailed them Friday morning does anyone know how long it usually takes for them to get back?

Support works weekdays, so that only gives them the end of Friday and some of Monday so far.
From my timezone of UK GMT+0, most of the support responses arrived at between 01:00 and 04:00 in the middle of the night.

I posted some additional details of the resetting process for those that are new to this. Rereading my steps; 1 and 2 should be swapped but the process of pressing and waiting for the RED LED is the same.

In the event your machine is already in the powered up state, (i.e. power button is lit) I am fairly sure this will not work.

If the EC is in a panic state it may try to autopower on as soon as a charger is connected in an attempt to clear or migrate its state to a known stable one. I have written code in the past that did just that; though this was in the late 90’s.

Once you connect the charger, wait a good 45 seconds to make sure it is not powered on and for any subsystem to enter a steady state.

Summary

If your power button IS lit, press and HOLD it for a good 20 seconds. This will force the EC to enter a shutdown state.

If it truly is all scrambled, you may need to disconnect the battery, then try pressing the power button (I know it sounds dumb but it will clear any residual stored charge), then reconnect the battery and try to boot the machine, before trying to reset the mainboard again.

I am trying to not talk out of my @$(^ here; just trying to suggest some tips to bring your FW16 back to life.

So, I had this issue when I first got my laptop and the issue was my RAM. What’s really odd to me is that your kit was working before the BIOS update.

I wonder what changes for the RAM subsystem are in the 3.03 BIOS from the Shipping BIOS.