AMD 7040 Framework 13 sometimes will not POST


I have had an AMD 7040 Framework Laptop 13 for a couple days, and it was working fine. However, today it no longer POSTed: when I press the power button, the fingerprint reader turns on, but the display remains black and I see no LED error code. It never displays the framework splash screen.

I’ve tried powering it on with and without AC to no avail. It looks like what one gets when the board is memory-training, but it used to work fine without me changing the memory and I’ve let it hang for more than 15 minutes to no avail.

The laptop is on BIOS version 3.0.3.

After reseating the RAM and trying it at least 2 more times, it finally boot back.

This is not the first time this happened to me, but the previous times a force reboot did the trick. My AM5 desktop seems to also exhibit this problem?! I’m not sure it is related, though.

Before I open a support ticket, is there something really dumb I am missing? Have you ever had this sort of issues and if so did you find a way to solve it?

1 Like

Do you use supported RAM? Which model and how much? One slot or both?

I use a single stick of 32GB Crucial 5600Hz RAM (CT32G56C46S5). I have it plugged in slot 0. It’s not in the list of officially supported RAM I think, but it’s a fairly standard model so I’d be surprised if it does not work.

I’ve also had a similar issue with my framework recently.
It’s gotten to the point where the laptop can charge, and I get blinking red lights when I open up the input lid.

I’ve tried removing, the SSD, and ram modules, swapping them around.
Tried turning it on with the power button on the main board.

I’m still waiting on support to back to me.

Any other ideas on what I can try in the meanwhile?

Okay the problem is happening on almost every start now. I think I’ll just contact support.

I think you’re having a very different problem though?

The blinking side lights are the chassis intrusion switch – it’s warning you that have the laptop powered on while the input cover is removed (the chassis is open). Do not touch anything inside the laptop while those lights are flashing.

1 Like

I noticed a similar issue on my machine, where it refused to post and/or it took a few minutes before it started displaying the Framework Logo. Once the charing LED blinked in several different colors before it posted.

Is there a list to debug those color codes?

But when I got my notepad and stopwatch to collect some information, the issue disappeared.

Edit: By “different colors” I mean green, blue, etc. Definitely not the chassis intrusion signal.

1 Like

That sounds a lot like the problem I am having. What RAM do you use?

Kingston FURY Impact 2x16GB KF556S40IBK2-32

It’s good to hear that it is happening on multiple brands and configurations of RAM. Sounds like it may not be a RAM issue. Hopefully it’s just a BIOS problem.

My Framework Laptop (Intel 12th Gen Intel® Core™) is not powering on
This should work for Ryzen considering there’s no article for it specifically, but not entirely sure.

Did this ever get resolved?

I just got my Ryzen 7040 laptop this week and have yet to get it to post. I have a Crucial 5600 MT/s (CT2K16G56C46S5) kit but also tried a 4800 stick with no luck. Hard to tell but doesn’t seem like the display backlight is coming on.

If the debug codes are the same for the Ryzen mainboards, all system checks are flashing green but then I am getting a post code of 0xA3 (BGBGGGBB). Someone posted a link to a GitHub file in this thread with definitions but A3 isn’t in the list.

I’m going to try and reset the mainboard while I wait for support to respond.

A3 is in the list: #define SMM_S3_SLEEP_CALLBACK 0xA3 // Enter S3

Wow, assumed things would be in order, that’s what I get for not doing a search

Do you have anything magnetic on the left side of the laptop that might be triggering the lid closed sensor?

Personally I don’t, but it’s weird because my problem seems to have solved itself? That’s not a very comfortable feeling but at least the computer works I guess…

Appears my issue is due to some bad pins on the slot 0 SODIMM socket. Got into contact with support and was taking pictures when I noticed pins 4 and 8 were recessed further than the others. Tried booting with memory only installed in slot 1 and got the system to post. Verified both modules work just to be sure.

I’m not sure when the pins got damaged but did noticed that the sticker identifying the slot was not attached to the board when I received it. Should have probably inspected the pins then. Would have preferred a bad module over the socket though…

Little annoyed to because I tested with one module only but only tested in slot 0 apparently.

I would double check the pins on your SODIMM socket. Could be a few pins with bad tension that are periodically losing contact. Hopefully you get to the bottom of your issues as well. Things fixing themselves always leaves me a little uneasy.