Framework 16 No Boot at the start

Looking for some help with a new unit.

I’ve taken this thing apart over a dozen times trying different configurations. Brand new Framework 16. Single Ram stick 32GB purchased with the unit from Framework. Single SSD also purchased with the unit. So all Framework parts.

After assembly all I get is the power button light will light up. Nothing is flashing on the indicator light, just the charging indicator. The fans will run as it heats up, but no response on the screen at all. I’ve let it sit for 20+ minutes with the RAM stick in each slot. I’ve pulled the battery and reseated the battery. I get nothing. I’m a bit stuck on what to try next. Nothing appears damaged. I would expect the screen to at least pop something during this process.

I opened a ticket with Framework yesterday but haven’t heard back yet.

Suggestions on what to check?

(I actually purchased 2 of these and the other one I have is working…so its not me :slight_smile: )

Try the known-working memory stick from the other laptop?

I swear I tried this already…it worked. One bad stick of RAM. I had them both open and was playing with different configurations of a stick in each slot…I tried 2 in one. I must have missed trying just this stick in my first go. It is for sure a bad stick of RAM. I’ll have to wait for the response on the support ticket to do an RMA.


So glad you found out it was a bad stick of memory. The RAM lottery is pretty sparse with duds. I can count on one hand how many times I have had a stick of RAM go bad in all the years I have been working on computers. Rare, though it does happen.