[SOLVED] FW16 Laptop won't boot :(

I assembled my FW16, no issues at all, then started it up for the memory training (following all instructions). 45 minutes later - no boot. It’s on and running (fans even spun up) but never got to the BIOS, etc. I have 2 RAM sticks installed, could it be that “it only will boot the first time with just one RAM stick installed” problem? Any ideas? Thanks!

I’m experiencing a similar issue, and I’m currently in communication with support, they’ve been very helpful! Out of curiosity, what RAM are you using? Mine is the G.SKILL Ripjaws 5600 2x16 kit, wondering if there’s a pattern here

Also check out this thread if you haven’t already: Framework 16 (Batch 15) No Power (battery or AC Power)

Thanks for the info!
It does appear to have power (power button lights up, fans run, etc.).
The memory is from Framework, and is just labeled as Framework DDR5-5600 Memory.
I have two 16GB sticks insalled.

Some memory shenanigans later it it’s working! Thanks!

1 Like

Greetings, which edition did you have?

I have the AMD one and was troubleshooting bc mem training is taking a bit and I’d like to have some insight before I go and inundate support with a ticket :stuck_out_tongue:

Hey @Keith_Andreano what memory shenanigans are you referring to?

I have this same issue. Power, but never booting up.

Using the framework provided ram on the AMD Ryzen 7040


I saw other posts mention taking out and putting back in the battery. So I tried that and it works now.

I followed the below guide, left the battery out for a few mins, then put it back in. Reassembled the whole thing, plugged in, powered on and after about 1 min everything came on!

Hi, didn’t do the battery trick, but removed the RAM and put them back one at a time (booted with just one, then with two). Booted no problem after that.

FW16, others have had the same issue. Some FW16s won’t boot (for the first time) with both RAM modules installed.