Brand new 16" won't turn on

I just finished assembling my laptop. I followed the instructions carefully. However, when I try to turn it on, nothing happens. The orange charging light is on, and the border light around the power button comes on, but that’s it. Nothing on the screen, no fan, nothing. I hope this is something simple.

How long have you given it? As I understand it, the system requires quite a bit of time to put anything at all on the screen on the first boot, as it checks things out. I don’t know the actual amount of time involved, I’m guessing it’s more than sixty seconds and less than fifteen minutes.

I’ve also seen reports that Frameworks have problems when used with two sticks of some kinds of memory, but work just fine with a single stick. If you’ve got two sticks of memory, try removing one and seeing if that helps.

If all else fails, there’s always Framework’s support. :slight_smile:


It was the memory. After reading another thread, I pulled it out, put it back in, put everything back together, and it worked.

Installing Debian now!

Thanks for the quick response!


:tada: :laughing: :+1:

I’m seeing this a bit late, but I was going to suggest booting with just one stick of RAM. Seems like a few people have experienced that. I figure that’s what I’ll try if I run into that issue when I get mine (batch 13).