Framework generally unstable, multiple hard Windows freezes per week, bios error monthly

My Framework DIY Batch 6 has been unstable since I purchased it. I have Windows 11 installed on it which hard freezes several times a week. There is no no blue-screen, it just freezes the current screen requiring a physical reboot. About once a month I will get a “boot device missing” error from the bios. After a few hours, sometimes longer, sometimes less, it will be able to boot up again. I’ve seen various similar problems reported on this forum but it is hard to tell if they are the same cause.

Is it likely I have a hardware issue like a motherboard problem? Are these issues a known/common? I am on bios 3.07, will upgrade to 3.10, but are these problem known to be resolved with the upgrade?

What do you recommend I do?

Contact support. They will help you troubleshoot and be able to better root cause the issue. They’ll also be able to offer you hardware replacements if they determine it’s necessary through troubleshooting. They typically respond within 1 business day.


Thank you, will do, but I am quite tech savvy, any ideas what I could check on my own while serviced gets back to me?

I would like to add that the BIOS recognizes the SSD. I guess it must either be damaged/wiped or something happened with the boot sectors. If I run a linux live disk, what tests should I run? First I should see if it has any data. If so, I should probably check the boot sectors? What would be the best way to do that?

Just as initial troubleshooting steps, I might try re-seating your RAM and SSD to rule out bad physical connections there. Also running chkdsk and sfc (from Windows) to check your drive and system files for errors.


From my experience, most intermittent freezing issues are due to bad memory. If you’re looking for something to do, install Memtest86 on a USB stick and give it a spin: MemTest86 - Download now! (the free version is fine).

I’m curious why you haven’t tried BIOS 3.17

You may have a poor connection with the RAM or something.

3.17 is still in beta. I wouldn’t recommend it as a solution for fixing instability issues until it is released as stable by framework. Installing BIOS 3.10 could be advisable, though.

That was way back in Nov and all seems fine, well for me since it was available and I’ve no issues.

That may be what he said, but until it has been formally marked as stable, I wouldn’t recommend it just to err on the side of caution.


I booted up a linux live disk to check what’s going on. I think the issue might be the nvme drive. When I fdisk there are no partitions, just a single nvme0n1 full disk. I am unable to mount it. Nor ntfsfix it. Nor chkdsk it. When I nvme list it shows only one entry: /dev/nvme0n1 and under “usage” it shows 2tb / 2tb (100% full?). When I smartctl -A /dev/nvme0n1 it shows 0% for “percentage used” and 0 critical_warning’s.

Is the drive fried? Is there anything else I should test?

Thanks for all your help!

1 Like
  • Which NVME are you using? What firmware version does it have?
  • Do Live-ISOs work (as in: no locks/freezes over a longer period of time)?
  • Did you install the driver bundle from framework?

I’ve had issues like this but they were solved after upgrading the Framework and NVME firmware and setting a kernel parameter.