Framework Laptop 13 Intel (13th gen) slow to boot, freezes on sleep or reset after battery drain

Hi guys,

So I unwittingly let my laptop battery drain completely. After plugging it in and letting it charge for 20min or so, I tried booting it. The white light under the power button came on, but nothing else happened. No screen, no fans, nothing. I held the button down to shut it off and tried again.

I thought it wouldn’t power, but I just left it after trying to turn it on, and surprisingly, the screen eventually lit up (After about 2min), the bios screen, and eventually the OS booted. the system again felt like it had froze during the OS boot (fedora 39), as it took >10min. But after trying again a few times and just being patient, it eventually booted. And mostly runs fine.

Two other things I noticed - if I try to restart, it shuts down the OS and goes to a blank screen (but the screen is still on), the fans start spinning, and the machine gets really hot. It doesn’t actually shut down. It also doesn’t power off without me holding the button down. I’ve let it sit like this for >10min, so I’m not sure if its just about being patient.

I get a similar state if I close the lid and re-open it. The machine comes back to the OS, but quickly goes into the blank-screen-and-fans-spinning mode.

I’ve tried doing hard resets (holding the power button to shut it off and then booting back) a few times. The long boot time, et cetera, remain.

I thought it might be an issue with the cmos battery or need a motherboard reset, but I also thought that was only 11th gen intel machines. Mine is 13th gen.

Any ideas?

update - the system now randomly freezes, sometimes while running fedora/gnome, sometimes just at the prompt for my LUKS password, sometimes at the grub menu. the fans are on full blast and the machine is physically hot.

Any help here? The machine is completely unusable.

Things to try:

  1. Reset the bios to default
  2. Reset the main board
  3. Boot from a live USB
  4. Run memtest on the ram and/or remove one stick of ram at a time

See if any of those helps. Best of luck.