Framework Repairability Issues

This is going to go on about my experience trying to get my Framework 13 repaired. I don’t know if this is representative of other’s experience, but I believe it is important to share my experience.

Honestly, this has been an awful experience. I started the ticket in October, and I still don’t have a working laptop. So far I have done countless tests and recordings for support, two main board replacements, fresh OS install, and sent in the laptop for repair. During this time, I have found out very little why my laptop is broken. I’ve been trying to be patient with framework, but I’m just so discouraged when my laptop’s repair process takes 25 days, and they send it to the wrong address once it’s fixed. The support team has been nice and respectable but unfortunately unhelpful. This can be seen by the fact that it will soon be 5 months since I opened the ticket. I don’t believe I’m being unreasonable when I say that this is unacceptable for a “repairable” laptop company.

As of now, I had to redirect the delivery to a collection centre to avoid DPD sending my laptop to the wrong address. I haven’t been able to test the laptop yet, and no information has been given as to what was repaired on the laptop.

I don’t know what the aim of you post is. Normally a community post would be asking for help, but you do not describe anything with regards to what is actually wrong with the FW13, so I don’t see how the community can help you.


I’m just trying to give feedback and hopefully draw attention to an issue I’m having. I thought this was a form for general topics form and not the support form. I assumed it would be fine because this isn’t the only post talking about framework support. If there is a better place for this, tell me and I will move the post to there.

1 Like

Sorry to hear you’re having such a bad time. If the repair process takes 25 days (ouch), for the other three-to-four months since you opened the ticket, how much of that was you, vs. support, vs. shipping?

Out of curiosity, what broke originally? Three motherboards is a lot, to all have the same problem.

1 Like

As others have noted, I’m sorry to hear you’ve had a negative experience. However, without details, this thread won’t be helpful to anyone. Which laptop do you have? When did you buy it? What are the symptoms of the issue? What troubleshooting did they have you do before you sent it in?

As for sending it to the wrong address, did you move addresses during that time? What country are you located in?

It seems like you left a lot of info out of this post, which makes it difficult to get any useful feedback out of. If your goal is to get attention from someone at Framework, the correct way to do that would be to ask for an escalation in your existing ticket, rather than posting in the user forum.


Welcome to the community. Sorry to hear about your troubles. Are you able to share any details about the issue you are having that led to all of this? This is the general topics forum, so if you aren’t looking for help, this is a good place for the post. But I’m sure anyone who reads a post like this is going to be curious about the details. For instance, which version (Intel Gen 11/12/13, or AMD), which OS, what issue you are having, etc.

I will say that nothing so far really speaks to the repairability of the laptop. Not technically. I think it’s more just a comedy of errors that compounded to turn a bad situation (a broken machine), into an even worse situation (multiple failed repair attempts, shipping issues, etc.). But again, that is only based on the info provided so far. Not that this makes it any less of a nightmare for you.

The reason I say it doesn’t technically speak to the repairability (or lack thereof) of the machine itself, is because this kind of tough to nail down issue can happen in any industry with any piece of equipment. It could be a multi-hundred-thousand-dollar piece of industrial equipment for which I have the schematics, but the wire that broke loose from a diode inside a massive wire harness and which rests in place just enough to make connection 19 out of 20 times the equipment is used and only fails that 20th time and never when I’m testing things can be frustrating for me and can be absolutely maddening for the end user. But it’s just one of those things that can happen. Sometimes, problems just kick you in the teeth and then hide in the bushes before anyone notices. But that doesn’t change the fact that, like the Framework laptop, every part of that equipment was available and replaceable. It’s just that some problems can be absolute…words I won’t say.

Sorry to hear about all the troubles so far. I hope you get a working, trouble-free laptop back soon. And if you need to vent a little on here, we’re here for you. But a few extra details can appease curiosities. And try not to let a problem like this sour you too much on the idea of a “repairable” laptop.


Hello all, Sorry for the slow response, it’s been a busy few days.
Lots of questions and I will try to answer. (clearly I didn’t provide enough information originally.)

I am running Intel gen 11 with Linux. (I keep an Ubuntu live USB for testing issues)

Okay so a run-down of issues and tests and solutions.

First, I had an issue with my storage. It would randomly disconnect (on battery or AC. on or off. In the bios or on OS). Originally I thought it was because I had a faulty SSD, so I decided to get a reputable SSD when I upgraded. That didn’t work, so I then tried reinstalling multiple different OSes. This took a while because the problem was weirdly inconsistent and wouldn’t happen all the time. Finally, I opened a support ticket, provided recordings and pictures, and got a replacement mainboard.

When I got this new mainboard, I immediately had issues. The new mainboard would cause the OS to crash as soon as it booted. This would happen on live USB or SSD. I eventually figured out it was something to do with the IO which was causing it to crash. If I took out the HDMI expansion port, and didn’t plug any peripherals into the laptop, it wouldn’t crash. Also, when ever I plugged the power cable in, it would have a 50 50 chance of crashing. Again I message in the support ticket, provide evidence, and they send a new mainboard.

Now the third mainboard worked better than the last. This one lasted 2 weeks before I ran into any issues. One morning, the laptop just wouldn’t start and wouldn’t charge. I went to the support ticket and they recommended a motherboard reset. This worked until roughly 2 weeks later when the same issue happened again. At this point, framework wanted to send me Another mainboard. I declined and wanted to send the laptop in for a full repair.

This is where the aforementioned wrong address issue happened. @Morpheus636 specifically asks about this, so I will go into details. I had moved address since I purchased the laptop, but I have updated my default address on my framework account and have been providing my new address for all the replacement parts I have been getting.

I finally got the now and It’s still got issues. The laptop doesn’t turn on without AC being connected in the morning. This has probably something to do with the CMOS battery, so I’m back to emailing support. I might go crazy if they recommend Another mainboard replacement.

Hopefully this has addressed all your questions.

With the description that you have given, it sounds more like a software bug than a hardware problem. Particularly as swapping the hardware has not resolved the problem.
I would be looking to get a “dmesg” log when it happens so one can identify which device driver is causing it to crash.
Is there anything in syslog that looks like a crash log?

1 Like

That definitely sounds like a dead CMOS battery.

It’s a shame all the issues you’ve had. Hopefully you can ultimately get a reliable laptop out of all this.

That sounds exactly like my 11th gen machine.

If you have some skill in soldering or have someone who can do it for you please follow this guide: RTC Battery Substitution on 11th Gen Intel® Core™ - Framework Guides.
There is a link in there where you can request the Substitute. That should at least help with the not turning on problem.

you just need to be carefull when inserting the Substitute in the holder. Some have broken it but could replave it anyway. Rework Instructions for 11th Gen Mainboards to enable powering the RTC circuit from the main battery - #325 by lightrush

1 Like

I installed the battery substitute module in my 11th gen laptop. I actually made a short video showing the process. It was definitely worth it for me.

I doubt Ferdinand is going to be too pleased with the idea of doing that kind of work on his machine to solve the CMOS battery issue. There’s also the option to just get a new CMOS battery. As long as he plugs the laptop in every couple days or so, the battery should last a long time.

It sounds like he already reached out to support about the issue. Hopefully, they explain the options and one of them works for him.