FW13 AMD not booting

Hi,
I got the FW13 AMD diy version with this configuration last Monday:
-System: AMD Ryzen™ 7 7840U
-Storage: WD_BLACK™ SN850X NVMe™- M.2 2280 - 2TB
-Memory: DDR5-5600 - 64GB (2 x 32GB)
(all from fw)

After installing the ssd and the memory I powered on the laptop but the framework logo is not showing. I tried it with only one memory unit and with both slots, with and without a usb boot drive.

The longest time I waited for it to boot was around 3h.

When I use an usb boot drive I get a “promising” sound playing after a while and can for example use the volume keys and get acoustic feedback but the screen stays dark and no framework logo or boot menu is showing.

Also the screen is “flickering” sometimes and gets brighter indicating that something was indeed happening in the background and sth new was loaded but its never displaying anything.

The small led on the side is blinking after a while and while the first sequence is completely green, the post code is the following:
ggbbbbgg (g=green, b=blue) (but I think I got at least one different post code at some point)

I contacted the fw support on Monday but since they are experiencing a high volume right now, I wanted to know if anybody has further ideas what to try.

I would try disconnecting and reconnecting the display connector. Also, if you haven’t already, you could try booting without the SSD installed.

Thank you for the suggestions. I tried now both, first booting without the ssd and also disconnecting and reconnecting the display (steps 6 and 10 from this manual Display Replacement Guide - Framework Guides) but unfortunately the problem still exists. The only thing that changed is the post code to:
bggbbbbb

Sorry to hear it wasn’t something simple (at least, so far). You say you contacted support on Monday (4 business days ago)? Have you checked your spam folder? I know they are really backed up, but I think they normally reply faster than that. I know they sometimes have issues with certain email services failing to let their emails through as well.

I hope you can get something figured out. Bummer to go a week with a new computer and not be able to use it.

Yes on Monday and I received an email confirmation for the ticket. I checked my spam folder right now, just to be sure, and there is also no feedback, yet. But they will then hopefully reply beginning of next week.