FW13-AMD: Internal display never wakes up after a HDMI connection

On FW13 AMD, with Windows 11, up to date.
I’ve only installed the FW driver pack, not updated AMD to their own recent drivers (because then the IPC latency becomes too problematic, see my previous post).

I’ve now twice experienced the following problem, but I can’t consistently reproduce it:
I will connect the FW to my TV to play media with the VLC app, through a FW HDMI expansion card (AFAIK, v3).
The TV will be the main display in Windows.

When I unplug the HDMI cable (not having put the main display back to the FW monitor in Windows), the monitor never awakens, it stays black.

I tried to plug it back into the Thunderbolt 3-dock, which it’s plugged into most of the times, with dual monitors, network, etc; but that didn’t do anything.

I was able to connect a USB-ethernet adapter and tried to do login in with remote desktop. I could not connect via Win RDP, it never succeeded. I could connect via Parsec (virtual display driver is not installed BTW), but everything was extremely lagging. If I moved the mouse or typed something, it would take ca 10-20 seconds to react.
Task manager did not reveal anything hogging the CPU.
I’ve tried to reset the GPU driver with the “Ctrl Shift Win B” shortcut multiple times, but nothing happened.

Windows Event log - System (not sure if related):
“A monitor attached to your hub or dock could not be enumerated by the USB4 Connection Manager. This may be expected if the dock or system does not have sufficient resources or bandwidth to support the monitor. ReasonCode1:0x14 ReasonCode2:0x0 Status:The resource requested is already in use.”

“DriverFrameworks-UserMode 10110 User-mode Driver problems.
A problem has occurred with one or more user-mode drivers and the hosting process has been terminated. This may temporarily interrupt your ability to access the devices.”

“DriverFrameworks-UserMode 10110 User-mode Driver problems.
The device Microsoft Remote Display Adapter (location (unknown)) is offline due to a user-mode driver crash. Windows will attempt to restart the device 5 more times. Please contact the device manufacturer for more information about this problem.”

Windows Event log - Application:
“Application hang
The program explorer.exe version 10.0.22621.3155 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.”

And about 10 of these, with varying messages:
"Windows Error reporting:
Fault bucket , type 0
Event Name: LiveKernelEvent
Response: Not available
Cab Id: 0

Problem signature:
P1: 193
P2: 80d
P3: ffffffffc0000001
P4: 44314406
P5: 0
P6: 10_0_22631
P7: 0_0
P8: 256_1

Attached files:

I could not figure out what the problem was. A reboot would solve it.

  • Has anyone experienced similar issues?
  • What could I do to troubleshoot further?