FW16 Batch 7 Guild

It’s on the truck now and the FedEx website doesn’t show signature required, so here’s hoping they won’t take it away again.
Still can’t set delivery options

Yeah, me neither. I’m at work. If it would be delivered tomorrow as they planned, it wouldn’t be an issue. Because I took a day off for tomorrow.

It arrived about an Hour ago. :smiley: And I already lost a screw. :+1: I took the second drive screw for now, but are there spare ones like on the 13? I didn’t found obvious ones. And the drive screw is too big.

1 Like

I got it, wooo :smile:
But it was super close, I just got out of my car when Fedex drove in the driveway, also no signature required

Booted right up after assembling it, didn’t need to relearn the RAM apparently

A few minor issues though, the input module is 0,9mm proud of the spacers (it’s aluminium so I’ll just bend it back), one of the connecting pads of the keyboard has ding in it (works in the BIOS gonna test more later) and the camera had no protective film on the bezel only the little tab to remove it

Now I’m off to setup the OS

1 Like

I’m still at work. But I got my FW16, too. Fedex driver contacted me on my smartphone and accepted to bring it to my workplace. Send him my location through WhatsApp and brought it to me. Had to show my identity card and sign for the package.

Worked better than I anticipated. Was probably easier for the driver anyway, because otherwise he had to drive 100 kilometers back to the Fedex hub.

Have to work until about 19:00 o’clock. After that time for food and then immediately diving into the notebook.


thats amazing!

1 Like

I was super excited to use my Framework DIY Edition… But mine came with a stripped or broken SSD screw. No matter how much I turn it, it wont come out. I cant install my SSD now… What do I do now?

mine arrived at the guy who’s forwarding it to me’s place today, should get it in my hands on monday. i’m so excited!!!

1 Like

Mine arrived today. I’ve already assembled it and installed Linux. I am suffering one glitch: connecting an HDMI screen. Still looking into it.

I bought top of the line and it is fast!

Will report HDMI status when I know more.


Update: I couldn’t get the Framework HDMI plugin to work, but I can use an external HDMI monitor if I

  1. Insert a USB C expansion card into port 4
  2. Plug in Letscom USBC002 hub
  3. Plug the monitor’s video in cable into the hub’s HDMI port

According to the documentation, ports 1, 2, and 4 should support the hub; the other ports should not. I didn’t try 1 or 2, but I am confident that the port would work in them as well.

Since other users have reported similar problems, I suspect resolution will take time. I have a perfectly good work-around, so I am happy to roll with it. We’ll see what tech support says when they respond to my ticket.

In all, color me happy. See you next time.

5 countries and counting. My laptop is having a backpacking holiday through Asia before coming to me it seems. :grinning:


Update: Silly me! I installed the OEM kernel and the HTMI expansion card now works a treat.
Moral: RTFM!

Even though I made a silly, N00B mistake, support was courteous and understanding. I give them five gold stars.

Thanks to everyone involved.


Get a tiny screwdriver, or better, some tweezers with thin sharp tips, and pull up on the screw as you unscrew it (to the best of your ability). That’s worked for me with stripped screws in the past.

Then, hope it’s the screw that’s stripped and not the SSD mount.

1 Like

I usually use needle-nose pliers or a multi-tool, just need to grip the sides of the screw head without slipping.

Peeps, what is this shipping:

7 countries in total. Finally gets to UK, leaves stansted, then ends up going back for second import release? What.

1 Like

The exact same thing is happening to mine currently as well. It went through release at Stansted yesterday, passed through another hub, and finally arrived at my local depot this morning. Now it’s passed back through Stansted and another release?

I hope they’re not sending it back!

I seemed to have gotten a busted keyboard, I’m messaging with support about it

It’s probably this:

Very possible. I see 3 issues here:

  • Fedex issue of not clarifying what is a prescan and actual location of package making the tracking kind annoying. Not Frameworks fault
  • Package has now hit 8 countries in total. This morning got a hit in Ireland? Am I on low priority shipping vs others who got there within 48 hours from Taiwan in the US?
  • What is this logistics? Why has it taken such an indirect route? Surely it would’ve been cheaper for the order to fly from Taiwan to France/Germany instead of going Taiwan > Philippines > China > India > UAE > France for most of the journey? I am just ignoring the last leg so excluding Ireland.

I dunno if shipping to Europe is just a mess vs rest of the world or am I missing something fundamental here? Did I miss shipping options at the end of my order? I can’t remember as it was from last year.

I posted my shipping manifest in the Batches Shipping Log - #247 by cenotaph.

My delivery to GER took almost the same route. Taiwan, Philippines, China and then to the Fedex hub in France, Charles de Gaulle airport. From then an exchange of information for the customs and then actual delivery to Cologne and from then on it started moving towards me.

I assume that either someone at Fedex made a mistake with your package or at the time there was no other transport airplane available. So they used another route.