[GUIDE] Framework DSP — better Linux audio

I can’t edit my original post anymore, so it’s here again :slight_smile:

A little while ago I’ve made and posted a DSP profile for Easy Effects

This time I’ve added proper response curve calibration with HiFiScan, and it sounds better than ever.

makeshift anti-echo chamber

So yeah, please do check it out :з

To install both previous and new profiles, just run the script in README
I won’t be adding it here, cause I won’t be able to edit it in a few months if necessary.


Weirdly enough, alas I like how it sounds, tone generator resonance testing show minimal improvements over the previous profile. I will investigate further tomorrow.

1 Like

Good stuff! Nothing to add, but this is great!


5dB correction was clearly not enough. Switched to 16dB by default, and now shipping with multiple other curves.

Guide recommends to use 27dB for notebooks, but it cuts volume too much for my liking. You can try different corrections in Impulse section, in Convolver filter.

Thanks for your work!

I had encountered an issue when running the command mentioned in the README (Paste commands to Terminal)

The error output:

sed: can’t read /tmp/tmp.gCJrsfCtg6/**/*.json: No such file or directory

Can I just import the config file to EasyEffect since this error appear?

Thank you!

Which shell do you use? (what does the echo $SHELL says?)
You can first try launching bash and doing it there.

(oh, or maybe globstar is disabled! I’ve just fixed it, try again :slight_smile: )

I wrote an install script because there are multiple files to install now and some paths to insert, but you can copy everything under the “config” folder into your easyeffects config manually, and then change %CFG% to your config directory in the json configs.

I’m using bash.

I got the same error output with the fixed version :smiling_face_with_tear:

It can’t be the same, at the very least there should be now one star in place of two… is it?

oohhh, sorry, one sec Yeah, now I’ve fixed the correct one. Please try it again)

1 Like

I fixed the problem by switching on globstar then enter the first version of the install command…

Yes, the same error output appear with another newer fixed command (with globstar on and off) :thinking:

sed: can't read /tmp/tmp.tSto9cLOsJ/*/*.json: No such file or directory

Anyway, thank your for your replying :melting_face:

1 Like

Hm, that’s weird. Do you have anything in /tmp/tmp.tSto9cLOsJ though?

Giving sed enough stars works for me: sed -i 's|%CFG%|'$CFG'|g' $TMP/framework-dsp-master/*/*/*.json

ohhh, I forgot the /config part D:

Yes, framework-dsp-master and fwdsp.zip

framework-dsp-master has output and irs folders with their files

And once again, fixed — please try again)

Still fails, framework-dsp-master is missing in the sed path, this works for me:

TMP=$(mktemp -d) && \
CFG=${XDG_CONFIG_HOME:-~/.config}/easyeffects && \
curl -Lo $TMP/fwdsp.zip https://github.com/cab404/framework-dsp/archive/refs/heads/master.zip && unzip -d $TMP $TMP/fwdsp.zip 'framework-dsp-master/config/*/*' && \
sed -i 's|%CFG%|'$CFG'|g' $TMP/framework-dsp-master/config/output/*.json && \
cp -rv $TMP/framework-dsp-master/config/* $CFG && \
rm -rf $TMP

phh. now this time it should be fine!

thanks for debugging!

1 Like

Thanks for creating the HifiScan preset, it’s great!

For everyone using a desktop environment where easyeffects system autostart thingy does not work:

easyeffects -l HifiScan+EEGuide --gapplication-service

This works in my sway setup, it would not start correctly without the --gapplication-service. I just start it in my sway config with exec


Thank you for doing this. You might want to explain each of the commands. sed in particular makes my brain hurt, and I can’t quite make out what that line is doing or is supposed to do.

While this all is (afaict, again, my sed skills are nonexistent) benign, people should not be in the habit of blindly running commands that they find on the internet, and explaining the steps would alleviate some concerns.

Again, thank you for creating this.

1 Like

The sed command searches (s) for %CFG% placeholders in all positions in each line (g) in the json files and replaces them with the content of $CFG, which is the path to the relevant easyeffects config folder.

While commenting the steps a bit more would help with understanding the script, I suspect having comments on such a script should not make you trust it more. An evildoer could write trustworthy looking comments not exactly matching the scripts function anyway.


Thanks for the explanation. As noted, my sed fu is nonexistent, so I got that it was doing a replace but not that it was looking in the file. I concur that one should not blindly accept comments at face value, but do feel that they would help one to verify what is being done. For example, after I read your comment I looked at one of the json files to verify the presence of the %CFG% string in there.

Thanks again, and have a good day.

1 Like