Headphone jack issues

Hello, I currently have the Base Configuration laptop with Windows 11 installed. Since I received the laptop, I have been having an issue with the headphone/audio jack. Whenever I plug in wired headphones, I hear a small beep as the headphones connect to the audio. This is accompanied by continuous static. If I don’t have any media or any audio playing for a while, the headphones seem to disconnect, causing another small beep, and the static goes away. Then, once I turn on a YouTube video or something, I hear the beep again and the static starts again. I am wondering if there is a way to get rid of the beeping and static. I tried reinstalling Windows 11, and I also installed BIOS 3.07, since the laptop shipped with 3.06, but neither seemed to help.


Many users (myself included) have reported the same issue here: Headphone jack intermittent noise? - #73 by BeeAPeach. I haven’t seen a solution yet for it and I’m still waiting for an answer from support. I recommend you open a support ticket as well if you haven’t already.

My apologies, I didn’t read all the way down that thread, but thanks for the information!

No worries, I just thought you’d like to know that others have experienced the same issue and be in the loop if a solution is posted. Hopefully Framework is able to fix this soon, it seems to have affected quite a few users.

I experience this as well. The best info I can find is that it’s an audio driver power management issue. I only experience it in boot (my headphones make the little beep, before the driver loads potentially or as it loads the first time) or alternatively in Linux if I turn on my maximum battery mode (which sets the Intel audio driver to maximum power savings and disconnect while idle), in which case it will make the beep every time the audio service is started or goes idle.

This is just a guess, but it sounds familiar to a problem I had, using windows 10:
At the beginning and the end of some music playing and being in idle, it would make a small pop sound.
I learned that this behaviour is related to the sound-driver and can be adjusted via registry.
Open the registry editor (type “regedit” in the windows search, it should pop up)
Go to: \HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class{4d36e96c-e325-11ce-bfc1-08002be10318}
(Alternative, you can use the search and search for “PerformanceIdleTime” and just go down the list until you arrive at an entry in a submenu named “PowerSettings”)
At this location, you should see a list beginning with 0000 and going upwards.
These entries are the audio driver references. If you click on 0000, there will be several entries like “ProviderName”, “InfSection”, “DriverDesc” that will help you figure out which driver you are looking for. For example you should have a Microsoft HD Audio driver entry. This is the default one, if you use Speakers or Headphone jack.
There you extend the list and go into the Powersettings folder.
There are 3 entries:

The next thing is figuring out which values work for which drivers.
For me I got rid of my problem by setting following values:
ConservationIdleTime = 00 00 00 00
PerformanceIdleTime = 00 00 00 00
This will prevent Windows Audio from ever going into sleep modus.

However, I had on other laptop brands the problem with some newer drivers, which would not accept the input of this values and just reset it on restart.
In that case you can go for:
ConservationIdleTime = ff ff ff ff
PerformanceIdleTime = ff ff ff ff
Which make the idle mode never end. The result should be the same.
This should get rid of the pop or beep you hear, when it goes into idle mode.
This should also work on windows 11.

If this does not directly help you, maybe this information pages from microsoft about audio devices might do: