Head's up for any Kubuntu 24.04 users

A couple things to keep in mind:

  • If you haven’t already done so, remember to go to the BIOS first and select “Advanced”, then go to “Linux Audio Compatibility” and select “Linux”
  • By default, the scaling is 100%; this includes if you go straight to the install. Therefore, if you don’t have really sharp eyes, remember to hit “Try Kubuntu” first, set the scale to a higher level, and then launch the “Install Kubuntu” app afterwards
  • Yes, fingerprint unlocking does work; but you need to install the fprintd package.
  • Using the standard / .deb version of Steam, it will run the first time, but not the second time. If you are ever in a situation where Steam doesn’t launch, open up konsole, launch steam via the command line, and then under Steam → Settings → Interface, uncheck the “Enable GPU rendering in web views”. Restart steam and now you can launch Steam without having to use the command line
  • By default, all Steam games will run via the integrated GPU. If you wanted to use the dedicated GPU, right click on the game in the library, go to “Properties”, and then under “Launch Options”, set it to DRI_PRIME=1 %command% and now the game will launch on the dedicated GPU. This does not work on Feral Interactive native Linux games! For that, you need to use the game’s launcher, under “Advanced”, make sure it selects “Radeon RX 7700S (RADV NAVI33)” and then it will properly run via the dedicated GPU.

Why does Steam not detect the GPU by default? Are there plans to have this fixed?

For Steam itself not launching, I think this is a DRI bug/issue that needs to fixed. I probably have to make a bug report for Steam.

For launching the games, its a bit more complicated since most games will render to whatever output DRI_PRIME tells it to. It’s just that right now steam doesn’t have a nice built-in way to launch a game with the GPU you want it to. In an ideal world, it would launch the game via the dGPU (or what you set as the default GPU) unless you right click on the game and tell steam to launch it via the iGPU.

Ah I see. If it’s just a matter of the environment variable being set then I suppose one could also change the shortcut to run DRI_PRIME = 1; steam or something?

Sadly no: https://github.com/ValveSoftware/steam-for-linux/issues/9383

The DRI_PRIME is for launching steam games rather than launching steam itself.

1 Like