[SOLVED] Steam on Ubuntu Phantom Launching to tray

Ubuntu 22.04
kernel - 6.5.0-1015-oem
followed instructions in the guides prior to this for ubuntu and steam.

Whenever I open the applications menu on Ubuntu and click steam, it launches to the system tray and my jet engine fan noise revs up, but no windows ever open.

If I click the buttons like “library, friends, etc.” nothing happens, except the “exit steam” button still works and exits the application after a few seconds.

The problem has something to do with the GPU selection and it causing a “phantom display”, because if I Right Click the application icon, and hit “launch with integrated gpu” it launches perfectly fine and I can interact with all windows until it’s closed again.

How do I either:

  1. Make the default launching option always integrated gpu?
    or
  2. Fix the dgpu launching of steam so i can actually see the windows that my computer is running?

Hey Stirling! I had the same issue on my Fedora 39 install. Could you try a few things for me?

  1. If you open a new terminal (Ctrl + Alt + T I think? Or find it under the program search) and type steam, does it launch Steam correctly? Or does it still have the issue you described?

  2. Can you run vulkaninfo | grep "GPU[0123]" -A 10 in a new terminal and post the output?

  3. You could try the solution in this post, but it didn’t work for me. Just kidding, I forgot to reboot. This did fix the issue for me!

Open up the steam.desktop file under /usr/share/applications and set PrefersNonDefaultGPU to false. Reboot/Relog into your machine. Problem should be solved.

  1. Other people mention disabling the switcheroo service in a terminal, but I don’t understand the ramifications of doing that, so I didn’t try it: systemctl disable --now switcheroo-control.service
1 Like
  1. Launching Steam from terminal via “steam” command does launch properly, however it is tied to the console window.
  2. Vulkan tools response:
vulkaninfo | grep "GPU[0123]" -A 10
WARNING: [Loader Message] Code 0 : terminator_CreateInstance: Failed to CreateInstance in ICD 3.  Skipping ICD.
GPU0:
VkPhysicalDeviceProperties:
---------------------------
	apiVersion        = 4206847 (1.3.255)
	driverVersion     = 96477185 (0x5c02001)
	vendorID          = 0x1002
	deviceID          = 0x15bf
	deviceType        = PHYSICAL_DEVICE_TYPE_INTEGRATED_GPU
	deviceName        = AMD Unknown (RADV GFX1103_R1)
	pipelineCacheUUID = e75ab6b8-f0a3-6b04-20f4-e8b7f1c24530

--
GPU1:
VkPhysicalDeviceProperties:
---------------------------
	apiVersion        = 4206847 (1.3.255)
	driverVersion     = 96477185 (0x5c02001)
	vendorID          = 0x1002
	deviceID          = 0x7480
	deviceType        = PHYSICAL_DEVICE_TYPE_DISCRETE_GPU
	deviceName        = AMD Unknown (RADV GFX1102)
	pipelineCacheUUID = e10a6cab-7e01-d585-a6dc-927c1b1fd8cd

--
GPU2:
VkPhysicalDeviceProperties:
---------------------------
	apiVersion        = 4206847 (1.3.255)
	driverVersion     = 1 (0x0001)
	vendorID          = 0x10005
	deviceID          = 0x0000
	deviceType        = PHYSICAL_DEVICE_TYPE_CPU
	deviceName        = llvmpipe (LLVM 15.0.7, 256 bits)
	pipelineCacheUUID = 32332e32-2e31-2d31-7562-756e7475332e

  1. This worked for me. The .desktop file was the culprit!
  2. I will probably also not do this.
    THANK YOU FOR HELPING ME!!! I no longer feel the need to abandon my linux dreams to go back to windows. :slight_smile:

I hit this roller coaster at least once a week :laughing:. I’m going to try my very hardest to never go back.

In case it’s relevant to you, I had some issues getting some games to leverage the dGPU. The thread is here, and the tl;dr is I had to set the startup command for the game in steam to be “DRI_PRIME=1! %command%” (The bang “!” is the important part). Not sure if this is relevant to you, but this helped keep my linux dreams alive!