Headset microphone? (on Linux)

I’m trying to use a headset with (TRRS?) jack on Framework laptop; the headphones are being detected, but not the microphone. Has anyone else encountered this issue? It’s unclear; is the 3.5mm jack headphone only (TRS), or headset (TRRS)?

It is a combo jack. It can do both

1 Like

Thanks @Josh_Cook. I found similar issues with other laptops. To answer the question for others who may encounter this on Linux, add the following line to /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel model=dell-headset-multi
5 Likes

There’s also Some notes on audio in Linux

What Linux flavor are you using?


Looks like a TRRS connection maybe?
If this pictures upto date.

Thanks, @Brad_J. @Ben_S, confirmed, it’s TRRS. I’m using Arch Linux.

I used to use Mint Cinnamon 18, it used to give me some problems with the headphones jack, since I moved to Mint 20 it’s been pretty bomb proof …touch wood.

Thanks @pbryan this completely solves my audio problems.

Hi !
Quick question - How to check that the modprobe conf is applied ?
I added this option, but no result.

Ok, it kinda worked - I can use my external microphone.

When it didn’t work, I used a TRS cable (which worked as a microphone cable on my old windows laptop).
Now that I use a TRSS cable, when connecting my mic (without a headset), the microphone is recognized as microphone+headset.
I don’t have any sound, because snd_hda_intel disconnects the speakers.

If you have any tips on how to force snd_hda_intel to NOT disconnect anything, it would be cool, thanks :slight_smile:
EDIT : Ok, with pulse you can force it

When I used to use Mint 18 the headphone jack would stop working after a couple of plugs/unplugs, some times to fix this I would open a terminal and type alsamixer

Make sure all the levels are up, nothing is muted and disable ‘auto muting’

Now I’m using Mint 20 Edge it seem pretty rock steady.

Anyone know if the HW can sense the button presses on wired headsets (Volume, Play/Pause, Mute, etc). (TRRS)