How to use old nvme ssd on DIY framework laptop?

I have a Western Digital 2TB WD Blue 3D NAND NVME ssd. I was using this on my old laptop. I have used cloning software before to transfer my os and data onto bigger nvme drives, and they have worked perfectly.

I want to keep Windows 10 and all my programs the same on my new framework laptop DIY 12th gen. How can I achieve this? I only have one nvme ssd that is big enough for my os and data and thats the one im using. I just want everything transfer over to my new framework.

I’ve tried physically swapping my nvme ssd and putting into my framework but it couldn’t find a boot device. I’ve tried using window’s recovery software from a usb while the nvme drive was installed but nothing :confused:

It’s just really frustrating because I have this amazing machine right in front of me but can’t use it how I want. I’m not that tech savvy, but from what I understand windows would need to “recalibrate” to the new hardware it’s given.

So what can be done in my situation? Any help is appreciated. Thank you for reading :slight_smile:

Your drive needs to be UEFI bootable. …and not MBR…

e.g. How to convert MBR to GPT drive to switch BIOS to UEFI on Windows 10 | Windows Central

1 Like

Second_Coming my drive was already GTP not MBR.
and my old laptop is using UEFI boot so I’m not understanding.

what must I do?

Odd…then the Framework Laptop should at least see the EFI partition on the drive when you drop that in…and show the Windows boot manager as a boot option.

Maybe someone else can chime in on what’s needed here.

1 Like

Not much more to add I’m afraid. I has similar problems to yours: I swapped a NVMe drive from an old laptop to the new, and it didn’t get deteted. In my case I didn’t have EFI properly setup and it was working on the older laptop because it still had “legacy boot” enabled, which is not available on the Framework laptop.

See if you can go in the BIOS on your previous computer and disable “legacy boot”. If it stops booting, that’s your problem: you’re not properly setup with EFI. (Then promptly re-enable legacy boot of course…)

If that’s not the problem, then I don’t know what it could be … NVMe blue should pretty much work out of the box, what model is it?


@John_Smith2 - I just did something similar a couple of weekends ago (not on a Framework machine). What wound up working for me was using a utility to copy the partitions over from the old MBR drive to the new GPT drive, creating an EFI partition on the new drive, and then running bcdboot from a windows command line as outlined here: How to Repair EFI/GPT Bootloader on Windows 10?. Please note that you will need to adjust things to suit your environment - drive letters, default language, and so on. I’m not particularly windows savvy, so I wound up purchasing a utility to handle the partition cloning. There likely are ways to do it with dd, parted, or the like in linux as well. I was more interested in completing the task efficiently so the cost of the utility was worth it for me.

Since you have only the one drive you presumably will be operating directly on it. If that’s the case, make sure that you have a backup in case things go sideways. What you will need to do will be to flip the drive to GPT, create the EFI partition, then use bcdboot to copy the files to the EFI partition.

Good luck, it can be done, it’s just a bit of a hassle.

1 Like

@lbkNhubert ok so I’ve bought a 4tb hhd and a usb converter so I can do a backup before I do anything. It’s arriving tomorrow. I’m a bit unsure of your instructions.

  1. Back up data, I’m going to use Macruim Reflect.
    (my drive is already in GPT)
  2. Create a EFI partition.
  3. Copy data to the EFI partition.
  4. Place into new computer and everything should work?

That’s pretty much it. Make sure that the EFI partition is FAT32, then use bcdboot to set it up for windows.

Good luck, I hope that it goes smoothly for you!

1 Like

I just wanted to give an update. So i bought a new nvme ssd with a higher capacity (4tb). I knew that Macruim Reflect was a good shot so I went for that, and it worked perfectly! I had to do a couple updates for drivers and such but all my data is on my new framework laptop! Kinda sucks I had to do it this way but I enjoy my new machine :). Im already loving it <3 Cloning software was the solution for me. Macruim Reflect just has the sauce, it does something to the bootloader that just makes it work!