I can´t finish the windows 11 setup because no Network is being detected


I got my 13th Gen DIY laptop two days ago and assembled it yesterday. When it came to setting up Windows 11 all went well until I was required to connect to a WiFi network. My WiFi module came pre-installed. While reading some Framework guides I noticed that there is a similar problem with Intel during setup but I have AMD. Another guide mentioned that when using windows the WiFi may not work until the driver bundle is installed but not how to work around that during setup. I restarted the Router but nothing changed.

What can I do?

Welcome to the forum :slight_smile:

If it were me having this, I would check my drawer of usb stuff and look for any old (known to work):

  • Ethernet dongle
  • WiFi dongle

and work around it.

Maybe you or a friend has such a device laying around so you at least keep moving forward.

1 Like

You could try the workaround from this post


Thank you both for for the fast reply’s.
Unfortunately we don´t have Ethernet/WiFi dongles at the moment but will be sure to remember since they can be bought. For now I will try the work around and see if that works.

1 Like

Shift/F10 When?
All I get is airplane mode on and off.

Hi @Alan_Estes,

I had a similar issue trying to offline install Windows 11 on a machine I built for work.

The Shift + F10 only worked at the LANGUAGE screen, not anywhere else in the install screens.

It threw me off, and I think the installer for the OS was updated and quietly disabled this from the WiFi screen where it worked before.

Luckily I had a USB-C dock with an ethernet built into it (Wavlink) and managed to not get stuck connecting my MS Account to the computer.