i7-1370P and AX201 WIFI on Linux?

Hello there, I just upgraded my 11th gen Intel board to i7-1370P, in otherwise fully working system, running Linux Mint. After booting up the system, I realized my Wifi is not working. In lshw I see only:

# lshw | grep AX
product: AX201 Bluetooth

I double checked if my wifi module is connected correctly and I don’t see any problem here. So the question is, is there any reason why AX201 module should NOT work with i7-1370P board?

Thank you!

The AX201 isn’t supported as it uses a proprietary cnvio2 interface. Framework only supports M.2 PCIe wifi cards. You will need to use a AX200 or AX210 for wifi & bluetooth to work correctly.

Framework sells the AX211, which as I understand it also uses intel’s proprietary CNVio2 interface. It’s just not supported on 11th gen mainboards. Not clear if it may work on the 13th gen.

1 Like

You mean, 13th gen Framework doesn’t support AX201 anymore? Because I got it with 11th gen and it worked flawelesly.

Ok, I upgraded to AX211 and it works now.