[SOLVED] AX211 Wi-Fi Card Won't Install Properly

11th Generation i7-1165G7
SK Hynix Gold P31 2TB PCIe NVMe Gen3
64Gb of Crucial Ram
Win 11 Pro, Version 22H2, OS Build 22621.1194
Bios 3.10

I recently bought the AX211 Wi-Fi/Bluetooth cards for both my 11th and 12th generation laptops. I downloaded and installed the updated drivers from Intel and the 12th generation installed with no problems, but the 11th generation laptop shows an error code 54 for Bluetooth and a code 10 for WiFi no matter what I tried.

I’ve tried uninstalling the drivers and re-installing, disabling and enabling the hardware, resetting Windows (reinstalling the Framework driver bundle) and starting over, but nothing works. I even tried swapping the AX211 cards in both laptops to see if it was malfunctioning. but the card that would not install in the 11th generation laptop, installed in the 12th generation laptop.

I’ve also contacted support but so far, no help. They were satisfied that everything worked when I re-installed the AX210 (no V-Pro), but they tell me the AX211 should work.

Any help would be greatly appreciated.


I’ve raised this up to our engineering team, but we’re not aware of any incompatibilities with the AX211. The fact that the AX210 no-vPro works without issue proves out it’s not a port issue. I’ll let you know when I hear back.



After review of technical sheets on the WiFi cards, the AX211 is not compatible with 11th Gen Intel Core, but 12th Gen Intel Core should work. If you are looking 6E connectivity on 11th Gen Intel Core, you should utilize the AX210 which is compatible and has the same wireless features. We’re not sure why it isn’t working on your 12th Gen Intel Core unfortunately as it should work without issue. We’re going to run some tests internally on AX211 on 12th Gen Intel Core to see if we can reproduce what you’re seeing.

To clarify, I have an 11th gen and a 12th gen Framework laptop. I bought two AX211s and it works perfectly in the 12th gen, but not in the 11th gen laptop. If its not compatible with the 11th gen, then Framework should say that in the description. Now I have an AX211 that I can’t use. BTW, I reinstalled the AX210 and it works perfectly.

If you saw my previous reply, I apologize, as I was looking at European inventory and we do not sell the AX211 there, only in the US and Canada. I looked up your order and saw that you purchased two AX211s from us recently. As you are within the return window, you can send one of the AX211s back to us for a full refund. Please contact Framework Support and I’ll make sure you are refunded after return, and we’ll also update the description of the AX211 to state that it is not compatible with 11th Gen Intel Core.

1 Like