[RESOLVED] Wi-fi adapter not detected

Looking for a little troubleshooting guidance. I purchased a refurb 11th gen intel DIY Framework laptop and put Fedora 38 on it yesterday. When initially using the live CD, the wireless card (Intel AX210) was detected and worked fine. After installing the OS to disk and booting up, the wireless card was no longer detected. I’ve tried getting the drivers from intels site and moving them into /lib/firmware but this didn’t work. Any tips on what to do? Thanks!

Hi @Michael_Sass,

This likely did not help and may have made things complicated as it is not needed on Fedora 38 whatsoever. So if the stuff below doesn’t lend itself to results, re-install (making sure wifi is absolutely seen on the Live USB Fedora 38 ISO - connecting to the internet)

Let’s start by making sure something isn’t blocking it. From a terminal:

rfkill unblock all


nmcli radio all on

If still not showing up:

lsmod | grep iwlwifi

Is iwlwifi showing as loaded? If not and with the Intel firmware added this may be a moot point now, try:

sudo rmmod iwlmvm && sudo modprobe iwlmvm

Report back.

Tried all the things you mentioned to no avail. But then did a hard reboot (holding button down) and upon reboot magically the wi-fi was working! Seems like a soft reboot will bork things. I saw someone mention this somewhere (but lost the link). Anything I can do to fix soft reboots so wifi card still works after? Thanks!

1 Like

Glad this has been resolved. :slight_smile:

1 Like

Does the issue happen frequently? do let us know, It may be hardware issue already.

@Loell_Framework , seems like this is an issue any time I do a soft reboot. Unclear to me if it’s hardware or software issue. This bit of troubleshooting advice (alciregi :fedora:: "@shellsharks@infosec.exchange @adamw@fosstodon.or…" - Linux.Pizza) seemed to be the most promising in terms of fixing it. Not sure if this makes sense to you (more than it does for me).

@Michael_Sass the post you linked suggests to,
remove the iwlwifi module and load it again.

which I think this one does, but apparently not working still for you?

My own experience is iwlwifi will fail to offload, but offloading iwlmvm will get it done.

1 Like