Wifi Problems with Intel® Wi-Fi 6E AX210 / Framework laptop (mainboard port issue?)

I received my framework laptop and at first install went well (windows 10 pro). Then I noticed I had no wifi. Found I had to install the driver pack. Installed that, and still no wifi. Wondering if I have a dead chip.

I checked my antennas. They were connected correctly. (but even so it should have still listed a device right?)

When I look in device manager, I see nothing related to wifi.
So I figure, ok, let me swap for a different card just in case.
This is where things got worse.

New card in, no wifi hardware detected in hardware. I go to remove second test wifi card, and the ground ring breaks off inside of the antenna wire. >_< Tried to fix it carefully using a needle… didnt work. Now the white cable wont hold on either.

I went from no wifi to needing a wifi antenna assembly and still have no idea if my wifi card is actually DOA or if i have a bigger problem with my board not detecting anything in the slot for wifi card.

I tried intel drivers.
I even tried intels driver assistant.
Checked bios version is up to date.
Tried a live linux (ubuntu) and ran lspci in a terminal. Nothing related to wifi.

Did anyone else have this much trouble getting a wifi card to be detected and usable?
About to just reinstall everything again since now im getting bluescreens and boot failures. EDIT: (fixed blue screen issues - updated ssd firmware)

Removed wifi antenna assembly to avoid any potential problems. Removing card as well.
Waiting on response from support on the matter :frowning:

1 Like

the card should be detected regardless of whether or not antennae are connected (assuming any hw switch is turned on). Have you tried reseating it? failing that, try a different known good card to determine whether its the card or the slot. DO NOT try the card in another laptop, in case its faulty in a manner that kills the slot or the motherboard (seen it happen with ram sticks)

Right, thats what I thought too. Hardware switches? None that im aware of. Does the framework have a hardware wifi enable/dissable switch somewhere?
Yes, tried reseating. Thats what lead to the damage of the antenna connectors. Im worried it did not detect the second card either. I will try one from the sugested list as soon as I can find one.

I made sure its not in airplane mode. But again even so, it should be listed in device manager. Waiting on tech support e-mail response. Hopefully we can get this sorted out.

Meanwhile im using a usb wifi 5 dongle to get by.

I have not heard back on wireless antenna module availability yet.
Are there any universal aftermarket antenna kits that may work?
Im looking at this MHF4 antenna kit for NGFF/M.2 but the wires seems excessivly long.

if it did not detect either card I would strongly suspect there’s a fault on the motherboard, sorry to say.

Yea… looking like it.

Adding to the thread:

Testing wifi card in ubuntu.

Framework laptop with wifi card purchased with laptop:

lspci | grep -i network
(nothing listed)

sudo lshw -C network
(nothing listed)

lo no wireless extensions.

Framework laptop with spare wifi card:

lspci | grep -i network
(nothing listed)

sudo lshw -C network
(nothing listed)

lo no wireless extensions.

Transfering card to another laptop:
Now if i take the original AX210 wifi card from the framework laptop, and put it in a a different laptop… (i know, dangerous if defective but I dont care about that old laptop).
Windows can see it. But it needs drivers.
Installed drivers.
Card works.

Both cards work in old laptop.
Framework laptop not recognizing anything connected to port. Tested both windows and linux.

Photo of AX210 card working in old lenovo laptop in windows: https://photos.app.goo.gl/YyRSLGzCT87ZQfmy6

Did a motherboard reset as explained in the guide.
Carefully removed CMOS batt. Carefully unplugged motherboard from main batt.
Waited 10 min and reconnected everything.

Main board light flashed red indicating reset was good.
System booted.
Still no wifi card detected.
Re-installed driver pack.
Still no wifi card detected.

Waiting to hear back from support at this point. Already reached out.
Still no word from them on antenna module availability.
Still no word from them on current issue.

Great news! Not being ignored. Just takes time.
Bee is awesome. Thanks for the re-assurance. :slight_smile:

1 Like

Received replacement antenna.

Reaching out to @framework again as i am still having problems this this laptop not detecting wifi cards on the mainboard. My original problem is not resolved.

New main board arrived.
Replaced main board.
Problem solved! :slight_smile:
Happy :3


I have the same issue. No WiFi card is detected after loading the operating system. :frowning: I have reached out to support on the next steps.


Having the same issue here, but it is a strange one as it was working yesterday without issue

But, I also literally just installed a new motherboard to fix an issue with NVMe, after a long-winded (2 months long) support ticket.

Am hoping I will solve this on my own before reaching out to support again. Just dropping a note here for public record

Unfortunately having this same issue with my new FW 16, here’s hoping support gets back to me soon