Intel wifi on AMD suddenly eating up 5W, any idea why?

I checked with bmon, and there isn’t really much going on. Tried on my mom’s wifi, same deal. It wasn’t like this until a few days ago.

Reset the motherboard?

(If you try it, please let me know whether it works or not.)

If that doesn’t solve the problem, I’d talk to Framework’s support team. They know more than I could. :slight_smile:

Gave that a try. It’s kind of an intermittent problem, so I’ll use it for a bit and see what happens.

There’s another thing that started happening recently, where it wouldn’t reboot all the way, and that doesn’t seem to have cleared up, so it might be something else.

Will let you know soon. Thanks for the advice!

1 Like

How do you know that the wifi is eating 5W? Is it that the overall power consumption of the laptop increases by 5W after you connect to a wifi network, or through some other means?
I doubt that the wifi card itself can consume 5W; it doesn’t have any fan/heat sink so it would probably catch fire in a short order if it generated 5W of heat… That said, I suppose it could prevent the CPU from idling, which could easily account for 5W…


Now it’s the bluetooth radio that’s sucking up 3W… not actively using any bluetooth devices.

I wonder if something’s just messed up with my radio?

Powertop has no way of knowing how much power the wifi actually draws, it’s just making an educated guess which in this case is likely wrong.

I wonder what it could be if not the radio itself? I’m not doing that much traffic on wifi, and certainly not on bluetooth.

I notice the 2.8W is 100% whereas the other are timed.

Could that mean the ms/s are those used in the time mentioned whereas the bluetooth is on all the time and the reading is for, as yet, an unknown time ~ Since last check ~ Since midnight etc.

What is ms/s ? Is it the time per second a service runs automatically ?

Second thoughts are you using sleep which accounts for a) the bluetooth 100% and b) the screen 5.9%

Pretty much anything, probably something powertop didn’t see during calibration

Yeah, I dunno, I tried recalibrating but it’s still accusing bluetooth of using 2.6W. And sure enough, killing bluetooth stops it.

The machine’s running a bit warm, and the CPU is idle, so it’s nothing actually happening in software.

Does the power consumption also go down by 2.6W when you do that?

Huh, good observation – no, it doesn’t. It only shaves off a few hundred mW.

I hadn’t done the math until now, but actually, the total of all the devices/processes doesn’t add up to the total power draw when the radio’s turned off. Only with the radios turned on it adds up to roughly the right value.

So maybe it’s just something about the new drivers/firmware/kernel that’s confusing powertop’s calibration.

Thanks, at least that clears that up!


Powertop is a pretty neat tool but if you are not very mindful of what it actually does it can backfire pretty hard. It makes educated guesses which can be right, they can also be quite wrong.

In this case it’s probably a case of “last power is higher now and bt has higher [insert whatever metric it got for bt] is higher so I guess bt is using that power”