Power Issues Abound

Howdy folks,

If you go through my post history, you’ll see that I’ve been dealing with some power issues. So much so Framework shipped me a replacement motherboard to address them. However, after installing the new mobo I started having issues where the wifi card would complain it lost power. After that I engaged support immediately and they suggested I re-seat the card and reinstall the driver pack. I did that last night and used the computer for about an hour before bed no problem. This morning, it’s dead and won’t boot. When I plug in the LED flashes green then would go to orange. Now that the battery is charged it goes straight to white. The bottom of the chassis is warm to the touch when left plugged in, but when I push the power button the LED cuts out and the screen stays dark. When not plugged in, the LED flashes green and then goes off. It got pretty cold last night so I assumed warming up would get it going again but no dice.

I relayed all this to the support folks in our email thread, but just got a canned email saying it’s faster to go through the forum. So here I am. Any ideas what I should do?



a) did you try resetting the motherboard

The ML1220 battery that runs the RTC (clock) and the CMOS (BIOS) requires 24hrs to charge, so once you’ve reset and hopefully powers on leave it plugged in.

When you switched off you may have had background, sleep, HDMI, BIOS looking for Internet etc. etc. So you must have the ML1220 charged as well as the main battery

1 Like

I have not yet, but I guess that’s something I can do next. I’ll leave it plugged in and hopefully tomorrow gives me better results.

1 Like

@William_Cook Very sorry to hear you’re having even more issues after the mainboard replacement. This is even worse than the previous problems we were having.

1 Like

I want to love this laptop so much. But how can I love it if I can’t even use the thing?

I reset the mainboard after support requested I do so and still no luck. Going to let it sit for 24h and see if we can get back in business.

1 Like

My previous laptop (which died less than a month ago, leading to my Framework purchase) had battery issues. I left it plugged in to try and charge it - all this did was make my laptop get hot and stay hot. Now it won’t turn on at all.

If you give it 24hrs to charge the RTC battery and it still won’t boot, I would recommend not leaving it charging unless there is another specific troubleshooting recommendation that needs it plugged in for some other reason.

But hopefully, charging that battery fixes everything! The battery issues are concerning, I hope this is resolved for you shortly.

1 Like

Unfortunately it seems like every time I have an issue it’s because the battery dies and the entire system is unable to recover. I’m practically afraid to ever undock it at this point.

No dice. Same behavior as yesterday, just 24 hours and change later.

Support asked me once again to pop out the RTC battery and let it sit out for 15 minutes, then try again. Still no dice.

Sure sounds like faulty hardware to me … sucks when it happens twice in a row.
Makes those of us with problem-free FWs feel bad!

1 Like

You shouldn’t! I really, really want Framework to succeed and even become mainstream! The more happy, satisfied people there are the better! But uh, I don’t think I’m going to be one of them this round. At this point I’m shopping around for something that at least will let me swap out the ram and storage I already bought and hope Framework just refunds me.

Support just asked me to take the coin cell battery out of the old mobo (the one that’s packed up and ready to ship back), install it in my new mobo, charge for another 24 hours, then try and boot without the wifi card and SSD.

I have requested a refund for my laptop and all expansion cards.

1 Like

Have you checked through the thread How’s everyone’s battery looking?

So your laptop is not even getting any display going? I presume it did when you installed from live media, but no longer??

Sorry to hear about your struggles, I hope you get a full refund.

Even worse. I used it for an evening after swapping the motherboard and aside from the Wi-Fi card losing power intermittently it worked just fine. But the battery died overnight and it hasn’t booted since.

That sucks! Was the battery low when you got off for the night? Or did it just drop like a stone from 40, 50, 60%?

Not sure specifically, but it was in low power mode, which I have set to trigger once it hits 30%. I would say between 30-20% left would be my best guess.

Luckily I just heard from support (an agent named Squid, shout out to Squid!) that they’re going to refund me and the RMA / Reverse Logistics team will be reaching out soon. I think the best replacement for me is a Zyphrus ROG14, mostly so that I can use the ram and ssd I purchased already for my Framework. Kinda sucks that this doesn’t work out but hopefully next time I need a PC things will be better and I can give Framework another shot.


Good choice!

I regret jumping in to be an alpha tester, and paying big for the privilege. This thing simply has too many issues to be taken seriously.

I don’t think that’s necessarily the issue. I don’t know what percentage of us are having problems considering that the big tech voices haven’t brought them up. So I wonder if it’s a QA thing. I do feel like I am an outlier though. My friends tell me I am cursed with technology despite having a very storied career in IT and software development :joy:

1 Like

The ROG14 looks like a nice laptop! Decently powerful! Very similar form factor to the Framework. Four USB and one HDMI port, so one more. The hinges lifting the body of the laptop up to an angle is an interesting choice… my last two laptops have died of broken hinges (destroying the displays) so I don’t think I would pick that up for that reason, but hopefully they’ve done the stress tests and it holds up!