Intel Wireless Network Adapter Issues

My Intel WiFi 6 AX201 is continually having issues, i.e. when the Framework is coming out of sleep or has restarted, the wifi device cannot be started. Usually I need to do a Start->Network Reset and reboot to get it running again. Has anyone else been seeing this?

1 Like

Welcome @Corwin_Yu - it’s good to see you here!

I’ve seen several folks with WiFi card issues, but I don’t remember seeing anything like this. Can you give us some more info? Is your laptop a DIY version, or did it come assembled by Framework? What OS are you running? Was it pre-installed or did you install it yourself?

Hi! Yes, this was a FrameWork Pro, it was pre assembled. It exhibited this behavior prior to any updates as well. I ran the driver bundle (July) and that didn’t squash the issue either.

1 Like

Yeah, it sure sounds like you’ve done everything right. :wink:

I hope someone else out there has experienced this and can help. If not, there are lots of Framework staff on the forums that are incredibly helpful (@nrp & @Kieran_Levin immediately come to mind), so maybe they will see this and get you pointed in the right direction.

Is it possible the device is being put to sleep? Since you mentioned a Start menu, I’d wager you’re running some version of Windows. You can see if Windows is putting the device to sleep under the device’s Power Management tab.

Device Manager → Network adapters → Intel WiFi-6 AX201 → Power Management → “Allow the computer to turn off the device to save power”


I’m having the same issues but there is no power management tab in device properties.

Have you tried changing the default mode for 802.11? My Wi-Fi card stops working every now and then, but manually setting the mode for 802.11n/ax/ac in the wifi card’s Device Manager settings to 802.11n seems to work ok.